G3100 port forwarding not working in SW 1.3.6.27
gburlingame1
Enthusiast - Level 3

Has anyone been able to get port forwarding to work properly on the G3100?

Other posts have been made and "solved" but the solutions are not real solutions.

There appears to be a bug in SW 1.3.6.27, HW 1103.

Thanks!

Greg

0 Likes
Reply
1 Solution
gburlingame1
Enthusiast - Level 3

So I double-checked what I called Method 2 -- setup port forwarding by entering the Firewall Menu and then selecting the Port Forwarding option.

While checking that, I recognized I was making a mistake in the configuration -- I was not leaving the Source Port at the correct setting of ANY.  After fixing that mistake, port forwarding worked as expected.

So to help others, if you are setting up a server on your LAN that you want others to access from the internet:

Source Port:  Any

Destination Port:  Port Number for your service

Forward to Port:  Port Number for your service

I will mark this ticket as SOLVED.

Thank you Dear dslr595148 Platinum Contributor III for sticking with this.

View solution in original post

19 Replies
dslr595148
Community Leader
Community Leader

Post 13 and 14 from https://forums.verizon.com/t5/Fios-Internet/Router-G3100-Port-and-port-forwarding/m-p/897934#M80848

@PedalLove wrote:

I have a G3100 ( HW: 1103, FW: 1.3.6.27) and have not been able to get port forwarding to work. Can anyone confirm that it does in fact work on this model and firmware? I've heard that there are some versions where it doesn't work at all. I'd like to know if my problems are caused by my settings or if the router has a problem.

Thanks.


@PedalLove wrote:

I solved my own issue and got port forwarding to work. I had to delete the entry in Port Forwarding Rules that I had set up for the port I needed and instead, specifically identify the ports in the Firewall - Port Forwarding section. It seems like creating a port forwarding rule for my application and applying it in the firewall doesn't work. In the Firewall section, I simply had to use the "Custom Ports" option instead of the application rule that I had created previously. Now it works!


Does that help you???

0 Likes
Reply
gburlingame1
Enthusiast - Level 3

Dear dslr595148 Platinum Contributor III,

I have tried both methods and neither has worked.

Method 1:  Define a rule under Advanced/Port Forwarding Rules and then apply it under Firewall/Port Forwarding

Method 2:  Make a new rule under Firewall/Port Forwarding

Super confusing naming -- horrible user interface design.  With that said, I have tried both methods and neither works.

Greg

0 Likes
Reply
gburlingame1
Enthusiast - Level 3

So I double-checked what I called Method 2 -- setup port forwarding by entering the Firewall Menu and then selecting the Port Forwarding option.

While checking that, I recognized I was making a mistake in the configuration -- I was not leaving the Source Port at the correct setting of ANY.  After fixing that mistake, port forwarding worked as expected.

So to help others, if you are setting up a server on your LAN that you want others to access from the internet:

Source Port:  Any

Destination Port:  Port Number for your service

Forward to Port:  Port Number for your service

I will mark this ticket as SOLVED.

Thank you Dear dslr595148 Platinum Contributor III for sticking with this.

dslr595148
Community Leader
Community Leader

#1 You use an inbound client side port checker like http://www.pcwintech.com/simple-port-tester or from https://portforward.com/help/portcheck.htm then be sure that:

you are forwarding the ports that you want to check and the server that you are trying to forward is NOT in the listening state.

Stated reason that the server that you make sure the server trying to forward is NOT in the listening state when using an inbound client side port checker, when using this kind of port checker - it will try to listen on that port and you can not have two servers listening on the same port at the same time.

#2 Or instead of an inbound client port checker:

a) Download and Install a packet sniffer. A packet sniffer like, tcpdump. But please note tcpdump is not the only packet sniffer that exist.

b) For tcpdump. tcpdump -p -n -i eth port 5154 would be a good command to start with). If you see incoming TCP SYN packets (not SYN/ACK), or incoming UDP packets from an IP which did not have an outgoing packet first, then the port is open.

c) and use a client side port checker like https://www.yougetsignal.com/tools/open-ports/

d) Note #1: If the port number is not 5154, then replace that port number with the one that you are testing.

e) Note #2: If the interface is not eth, then replace that interface with the one that you are testing.

f) Note #3: To test more than port...


tcpdump portrange 5153-5155

tcpdump port 5353 or port 8080

...or you can combine it...

tcpdump portrange 5153-5155 or port 5353 or port 8080

#3 Once you know that the port is open from the outside (not talking about from behind the router), see Port forwarding only works seen from outside my local network? 

#3 If you need any help getting the port sent through the router, please post.

#4 Likewise if you need any help getting the port to show as open after you use a client side port checker (or a packet sniffer and a web based port checker), please post.

gburlingame1
Enthusiast - Level 3

Dear dslr595148 Platinum Contributor III,

I am not sure if you are a human or bot, but I will assume for a minute that you are a well intentioned prolific Verizon forum poster trying to help as many people as possible.

I am familiar with methods for testing if ports are open which appears to be the intent of your post.  

  • Do you have a G3100? 
  • Have you used any of the methods in your post to test port forwarding on the G3100?
  • Were you able to successfully open a port on the G3100?  

Thank you for your help.

Best regards,

Greg

0 Likes
Reply
dslr595148
Community Leader
Community Leader

#1

a) I do not have FIOS or ever have.

b) I do not have any FIOS routers or ever have.

#2 While I do not have FIOS or any FIOS routers or ever have had FIOS/any FIOS routers, I have used the methods that I listed to tested ports with the router(s) that I have.

#3 No, see answer number 1a and 1b.

gburlingame1
Enthusiast - Level 3

Thank you for the honest reply and for trying to help.

Unfortunately tests do nothing but confirm what I already thought was the case -- port forwarding is broken on the G3100.

I called and spoke to LaTanya last week (on 5/21)-- she was unable to confirm or deny the problem.  She was also unable to get anyone on the phone who could troubleshoot a higher level tech problem.  She was supposed to call me back but she never did.

I plan on calling again tomorrow (Tuesday, 5/26).

Greg

0 Likes
Reply
gburlingame1
Enthusiast - Level 3

I just got off the phone with Verizon (5/26 at 10:00am ET) -- actually a third party company called Altius in India that Verizon appears to outsource certain tech support calls too. 

First I started with one woman and then we waited a long time to talk to a 2nd person who didn't have any of the info about why I was calling in -- had to start all over again.  Spoke to the 2nd rep briefly and that's when I got switched over to Altius.

The Altius rep had an Indian accent but fortunately he was intelligible.

He had me put the computer I was trying to port forward to into the DMZ.  Putting the computer into the DMZ did make the port visible from the WAN side.  Unfortunately that's not what I want to do -- I don't want to put my son's computer in the DMZ.

The representative reply was "sometimes with certain routers that's what you have to do".  I tried to explain no, that's not how it is supposed to work -- this is a bug.

I begged him to create a bug report, but it's not clear if he has the ability to do this.  I think he might have at least created a ticket that a customer (me) thinks there is a bug with the G3100 and port forwarding.  

A little bit frustrating to say the least.

Cheers,

Greg

0 Likes
Reply
dslr595148
Community Leader
Community Leader

For us helpers to better assist you, please take a screen shot at the forwarding page.

https://www.take-a-screenshot.org/

Then upload it here. Because of the ways things work, an admin/a mod will have to approve of it to show up - so do not be alarmed if it does not show up right away.

gburlingame1
Enthusiast - Level 3

Dear dslr595148 Platinum Contributor III,

Thank you for the offer to look at a screen shot, but that will not help anything.   Setting up port forwarding is actually quite simple -- I have done this many times on many routers.  Unfortunately there is a bug with the G3100 running 1.3.6.27 software.

I have a ticket in the system and hope that it leads to a solution.  I hope this bug is known and the next firmware release will address it.

Note:  There are several posters in this forum and in the Fios subreddit that have not been able to get port forwarding working on the G3100. 

Port forwarding is not a fundamental function of the router that most people use, but it is a a feature that some customers need and it is disappointing that the released firmware could escape with the feature not working at all.

Greg

0 Likes
Reply
dslr595148
Community Leader
Community Leader

Ok.

Q1 Since DMZ worked and you do not want to do that, a question. Is the issue something to deal with the firewall settings of the router?

If you are on the high level: Change it to medium, retest and report back the results.

If you are on medium level, for testing reasons only: Change it to low, retest and report back the results.

If you are on low level and it is not working: Please state that you are on low level and it is not working.

I also have these other questions.

Q2 While I get that you have FIOS Internet, do you also have FIOS TV?

Please note for this next question even if you have another one that is not use, you must say so. For example: Yes, but it is a spare.

Q3 Do you have a separate router?

Please note for this next question: One of the NICs must be a wired NIC and it should not be a portable type of computer (ex: a laptop).

Q4 Do you have spare computer that works that either has two NICs or you could add a second NIC?

gburlingame1
Enthusiast - Level 3

Dear dslr595148 Platinum Contributor III,

Are you still trying to find a a way to get port forwarding working or are you collecting more information for the engineers that would be working on solving it? 

I will answer your questions:

1) I tried all levels of the firewall High, Medium, and Low and port forwarding did not work with any level.

2) Yes, I have all Verizon's services - internet, TV, and phone.

3) Yes, I have many routers -- several of which I have used in the past and port forwarding worked great.  None of them are connected at the moment.

4) No, I do not have a computer that I could connect two NIC's too.

Greg

dslr595148
Community Leader
Community Leader

I have a possible workaround type of fix in the meantime while waiting for them to fix the issue.

I used Google or another online search engine to look up use your own router and have FIOS TV work.

And found out the following info.

#1 REF = https://www.wikihow.com/Use-Your-Own-Router-With-Verizon-FiOS

From part one step 3


Purchase a MoCA adapter if you have FIOS TV service. If you have TV service through Verizon FIOS, switching to a new router will prevent internet-specific TV features (such as the guide, On Demand, and the DVR) from working. A MoCA adapter should make your TV service work almost exactly as it did before. Some popular manufacturers are Actiontec and TRENDnet.[3]You may lose the ability to program your DVR remotely when using your own router. You should still be able to use regular DVR functions in your home.

#2 REF = https://forums.verizon.com/t5/Fios-Internet/Using-my-own-router-keeping-FIOS-TV-working-stopping-ren...


I just assumed you meant you were getting your own router. But if you buy a Verizon one then you don't need the MoCA adapter.

Like other poster said you can also configure a Verizon router to work as a MoCA adapter as well.



#3 Also found this https://forums.verizon.com/t5/Fios-Internet/Using-your-own-router-with-Verizon-FiOS/td-p/851632

and see the section Steps for users with FiOS TV

Another EDIT..

Same thread where Steps for users with FiOS TV and quotes a FAQ item.


Q: What services are affected when using my own router? A: The only known service that has issues is the remotely programmed DVR option for FiOS TV. No other services are affected (such as phone).

EDIT: Since posting, there has been a new article posted to DSLReorts with a solution for keeping remote DVR and Caller ID on screen: http://www.dslreports.com/faq/16710


🙂

gburlingame1
Enthusiast - Level 3

Dear dslr595148 Platinum Contributor III,

Thank you for the suggestion to use an alternate router other than the G3100 I just purchased from Verizon until Verizon fixes port forwarding in the G3100.   (FYI, the purchase price of the G3100 was $399!)

I have run other routers with MoCA adapters for many years but I decided to purchase the Verizon G3100 because it is a powerful device that fully supports all of Verizon's features -- one important feature is that streaming video from Verizon's TV boxes (VOD) does not count against your rate plan's capacity whereas it does count against your data pipe bandwidth if you use your own equipment.

With a busy tech family at home in the time of COVID-19 this is a nice feature.  

Greg

0 Likes
Reply
dslr595148
Community Leader
Community Leader

@gburlingame wrote:

Dear dslr595148 Platinum Contributor III,

Thank you for the suggestion to use an alternate router other than the G3100 I just purchased from Verizon until Verizon fixes port forwarding in the G3100.   (FYI, the purchase price of the G3100 was $399!)

I have run other routers with MoCA adapters for many years but I decided to purchase the Verizon G3100 because it is a powerful device that fully supports all of Verizon's features -- one important feature is that streaming video from Verizon's TV boxes (VOD) does not count against your rate plan's capacity whereas it does count against your data pipe bandwidth if you use your own equipment.

With a busy tech family at home in the time of COVID-19 this is a nice feature.  

Greg


Glad to hear/read.

Marking as solved, since you found that workaround.

Assuming that this thread does not become locked when it is to old to reply to,

we can change the Solution to the issue after it is solved for real.

gburlingame1
Enthusiast - Level 3

Dear dslr595148 Platinum Contributor III,

I appreciate you want to help, but I am very disappointed that you marked this post as SOLVED.  This problem is not solved.

I ask that you only mark this problem as SOLVED when port forwarding on the G3100 works as expected on a future firmware update. 

Replacing the G3100 with other equipment is can not be considered as a solution to "G3100 port forwarding not working in SW 1.3.6.27". 

The title of the post is not "Looking for a way to get port forwarding with Verizon Fios".

I kindly request that you unmark this issue as SOLVED as it is most definitely not SOLVED.

If you do not unmark it as SOLVED I will create a new ticket with the same information all over again.

0 Likes
Reply
gburlingame1
Enthusiast - Level 3

Dear dslr595148 Platinum Contributor III,

I just found the option to mark this thread as UNSOLVED.  

I'll mark it as SOLVED when it is really SOLVED.

Cheers,

Greg

0 Likes
Reply
dslr595148
Community Leader
Community Leader

Ok.

I have one least another test/thing to look at that you can do with the router.

Since the lowest possible firewall setting did not work and DMZ did, from the firewall page go to Access Control.

This is important because in the manual / user's guide REF https://www.verizon.com/cs/groups/public/documents/onecmsresource/home-router-usermanual_new.pdf

on page 88, it clearly states for Minimum level

Unrestricted for Internet Requests Incoming Traffic

with this note as what that means

Unrestricted - permits full access of incoming traffic from the internet and allows all outgoing traffic, except as configured in Access Control

Please be sure that the router access controls is not blocking what you are trying to do.

gburlingame1
Enthusiast - Level 3

I have not added any restrictions under the Access Control section.

Greg

0 Likes
Reply