Got a print server that insists on being, how do I deal with it?

Hi all. Got the latest and greatest router. All my devices are working fine on it except one lone print server. 

It worked fine back in the day when it was on an older Verizon gateway router that was configured as This little print server requested a static IP of 

But now, my new router gateway is on 

I tried changing the subnet mask to and, but no go. In fact, I can see the print server on the network when I arp -a in terminal. It's the only computer with 192.16.0.x against all these other devices as 192.168.1.x

I think the reason is that this little guy is expecting a gateway to be at, but alas, it's not there.

Can you create aliases on this G3100?  If so how?

I'm not that smart, but clever enough to get into trouble when it comes to routers. 

Many thanks.

1 Reply
Community Leader
Community Leader

Are you changing the subnet at the router's Network (Home/Office) page, or you are changing the subnet mask on your stubborn printer server? If you can change the printer's subnet, you can perhaps change its IP address too. More likely than not, you are changing the G3100's LAN subnet mask. This only permits routing from G3100 to the printer, not the other way around because the printer cannot send the packet to the nonexistent gateway.

So, why route at all? You can switch to the printer from other devices. Newly all computers support more than one IP addresses per NIC, just configure an additional IP address within the same subnet as the printer on whatever devices that need access to the printer. Then the traffic won't even pass the router (at least the part that makes a "router" a router).

Another thought, can you just change G3100's LAN to

I hope you understand my suggestion here. Since you know how to configure the subnet mask, I am assuming you have some experience in computer networking.

If you have more questions, I am happy to help.