HNP home network protection not activated
Enthusiast - Level 1


I have the new G3100 router, everything is working except for

Home Network Protection (HNP), parental controls. 

I've been on the phone with Verizon, for a couple of months, it's still not working.

Basically it does not allow me to initialize the service, it says the HNP not activated and it does not allow me to turn it on.

So far they they tried.

1) reboot router

2) reset router

3) remove app

4) login and logout of app.

5) McAfee support also validated their software was working.

6) They sent me new router.

7) Connected to myfios with an unaliased user account.  (internal cryptic userid)

Basically this is the problem,  through the myfios app, I go Internet , and then Home Network Protection.

I get a red error message at the bottom, saying that "HNP is not activated on your


Sometimes after a couple of tries, I get the McAfee screen, on the bottom on the screen is a status toggle that activates the HNP, but it's inactivated (greyed out) on

my apple phone.  However I tried it on an Andriod phone, it's not greyed out, but I get an error trying to turn it on.

I'm running out of ideas.

Just wondering if anybody else with a G3100 is experiencing the same issues?

Re: HNP home network protection not activated
Moderator Emeritus

Hi nasal,

Your issue has been escalated to a Verizon agent. Please check your Private Messenger Inbox for a message from a Verizon Support agent. You can find your Inbox by clicking on your username at the top right corner of this page and then clicking the envelope icon that appears at the top of the menu. Response times may vary and may be delayed at this time. Please continue to check your Inbox for a reply from a Verizon agent. Please direct all correspondence concerning your issue to the agents who will be assisting you privately.