Help with netgear router

This is my setup.

verizon actiontech mi424wr-2 imac's and 1 pc
netgear wnr3500v2-macmini

wireless and internet works fine.can't seem to figure out how to transfer files between imac's and pc wit the macmini.i can connnect and transfer files to the imac's and pc from the macmini,but the imacs and pc can't connect to the macmini.all my share settings are enabled on all macs and pc.all basic settings on the actiontech and netgear. I assuming its the actiontech router,but i just can't figure out what settings i need to transfer files.Help Please!

Re: Help with netgear router
Community Leader
Community Leader

Nothing to do with the ActionTec ... it's the Netgear.  It's not a "problem", it functions that way by design.

You are using the Netgear in "router" mode.  This creates a one-way door of sorts for anything which attaches to the Netgear which lets traffic flow toward the Internet (which would include the PC's attached to the ActionTec) but doesn't allow anything to initiate traffic to hosts behind the Netgear.

You need to either reconfigure the Netgear to operate like a simple access point (changing the IP address of the Netgear, disabling DHCP on the Netgear, and moving the connection between the Netgear and the ActionTec from the WAN port to an open LAN port) or place the Mini in the Netgear "DMZ" (at which point the PC's and other Mac's will see the Mini as having the IP address of the WAN interface of the Netgear.

Depending on which you would like to do, someone here can provide you instructions.

Re: Help with Netgear router
Master - Level 1

The information in your post is insufficient to answer your question.

How are the two routers interconnected?

Is the connection from an Actiontec LAN port to the Netgear WAN port (LAN-to-WAN)?
If so, you have probably created two separate subnets that can't talk to each other (e.g.. 192.168.1.x, 192.168.0.x).

To fix this you have two choices:

1)  Create static routes in the Actiontec so that it knows how to route between the two subnets you've created.  Or,

2)  Connect the two routers LAN-to-LAN and disable DHCP server in one of the two routers as Lasagna suggested.

If the routers are already connected LAN-to-LAN, then you will need to post more information.