High latency
Enthusiast - Level 2

I've had my service for about 2 years now, at first all was great, I had great speed and no problems after about 6 months I started to see inconsitant speed, i'd get great speed then it would drop down to under 1mbps.  Starting a few months ago i'd get great speed 50% of the time and bad the other half.  I also had another problem, whlie experiencing slow speeds I decided to restart my router and when it came back on i lost internet connection,(the internet light went out on the router), the connection would come back the next day, after the 3rd time this happened (this past friday) I decided to call verizon, they said the problem with the internet cutting off and my inconsistant speed were most likely due to a bad router and they shipped me out a new one.  I set my new router up today it is a MI424WR-GEN3I and I'm still experiencing slow speeds and really high latency. For about an hour I actually managed to get above 15mbps and ping below 10ms then I noticed the slow down in my speed.  Running speed tests on speedtest.net I got 799 ms 0.41 Mbps down and 0.72 Mbps up, Trying to take the fios speed test  resulted in an error stating the test timed out and that I shou'ld try again later. 

Anyway my router is a MI424WR-GEN3I I have WAP 2 security, I have 2 computers set up one running windows 7 and the other windows 8 both experience the same speed issues, as does my PS3 that i have connected.  I've tried restarting the router several times and doing a factory reset to no avail.  I ran a tracert verizon.net and google.com and here are my results:

Tracing route to verizon.net []
over a maximum of 30 hops:

1 2 ms 1 ms 1 ms Wireless_Broadband_Router.home []
2 430 ms 443 ms 458 ms L100.NYCMNY-VFTTP-32.verizon-gni.net []
3 547 ms 550 ms 569 ms G0-14-4-5.NYCMNY-LCR-22.verizon-gni.net []
4 711 ms 709 ms 715 ms ae0-0.NY5030-BB-RTR1.verizon-gni.net []
5 771 ms 777 ms 795 ms so-4-0-0-0.DFW01-BB-RTR1.verizon-gni.net []
6 846 ms 880 ms 1046 ms so-1-0-0-0.DFW03-CORE-RTR1.verizon-gni.net []
7 * * * Request timed out.
8 * * * Request timed out.
9 876 ms 892 ms 930 ms
10 922 ms 933 ms 925 ms

Trace complete.

Tracing route to google.com []
over a maximum of 30 hops:

1 1 ms 4 ms 1 ms Wireless_Broadband_Router.home []
2 567 ms 585 ms 589 ms L100.NYCMNY-VFTTP-32.verizon-gni.net []
3 583 ms 596 ms 654 ms G0-14-2-5.NYCMNY-LCR-21.verizon-gni.net []
4 773 ms 812 ms 902 ms ae0-0.NY325-BB-RTR1.verizon-gni.net []
5 978 ms 947 ms 628 ms 0.so-0-0-0.XT1.NYC4.ALTER.NET []
6 338 ms 234 ms 243 ms TenGigE0-6-0-0.GW8.NYC4.ALTER.NET []

7 270 ms 362 ms 375 ms google-gw.customer.alter.net []
8 569 ms 574 ms 603 ms
9 711 ms 628 ms 659 ms
10 1029 ms 1057 ms 1056 ms lga15s29-in-f0.1e100.net []

Trace complete.

Any help on resolving this would be greatly appreciated.  Please let me know of any other information i should post

Re: High latency
Specialist - Level 2

One easy thing to try is changing the DNS server. I executed the same 2 tracert commands on my system and none of the hops were more than 80ms (most were less than 20)

See this post http://businessforums.verizon.net/t5/FiOS-Internet/Can-I-enter-Google-DNS-in-MI424WR-Gen-2-router-mo... for details I am using the google DNS settings mentioned in the final post

Re: High latency
Enthusiast - Level 2

Thanks for the reply, funny enough right after posting my original post I searched online for a few solutions and I ended up switching my DNS server to openDNS and google, neither seemed to help.

Another problem I noticed is on my laptops that are connected wireflessly I have internet access (i can surf the web, stream videos and music and download files) but my internet connection symbol shows a yellow triangle and says limited connection, and sometimes it'll say "no internet connection" this is on both of my laptops, one running windows 7 and the other windows 8.

Any help to either problem is appreciated!