How to force an update of G1100 Quantum Gateway firmware?
glugglug
Enthusiast - Level 3

I recently got the free G1100 router with my upgrade to 150Mbps.  I wired ethernet from the ONT to my own Asus router, so I don't actually need it for the speed, but I would like to use it as MoCA/ethernet/WiF bridge in a room that has otherwise weak WiFi signal and would be a pain to bring ethernet to.   The router arrived with a 1.04.00.10 firmware, which doesn't have any option to update it in the UI.

I really don't want to interrupt the internet use in the house to wait for the gateway to get activated as a primary router.    For now I set it up behind my Asus router in a DMZ, but this does not seem to be enough for it to pick up the firmware upgrade, even though it is definitely online and I can browse the internet connected to it.

I have to say I am impressed in a BAD way by the WiFi performance of the Quantum Gateway with the current firmware version.  My other routers get double the throughput going 50' through multiple stucco walls that the new router does from 3 feet away in the same room.  A lot of the settings are pretty buggy, for example, when I set it up as a bridge before just putting it behind my router to try to get the update, I had to add a route for anything connected to the G1100 through WiFi to get to the internet (ethernet ports worked without this route though).  Also it wouldn't allow this route to be entered with a 0.0.0.0 netmask (aka default gateway) but a 1.0.0.0 mask was treated as 0.0.0.0.  Lots of other flakiness seen, which I'm hoping a new firmware would fix.

0 Likes
1 Solution
jonjones1
Legend

If you read the article it states not to use Frontier firmware.

i also told you the firmware is not necessary since the router does not use โ€œRโ€ band.

i will attach a screen shot showing the absolute last firmware update.

if the numbers are the same then you are at the most newest firmware.

image

View solution in original post

7 Replies
jonjones1
Legend

What makes you think you donโ€™t have the latest firmware update?

verizon pushes them out as needed. Since there are no listed vulnerability for the G1100 (does not use R band) the firmware should be up to date.

here is a site that may assist you.

https://www.reddit.com/r/Fios/comments/5lssix/how_do_i_manually_update_the_firmware_on_the_fios/

0 Likes
glugglug
Enthusiast - Level 3

My firmware version starts with 1.04 and I see posts about 1.3.* from 2015.  I figured 1.04 < 1.3, but maybe 1.04 is really the same as 1.4 for this purpose?  If so, the state of it is pretty shocking..

I tried what it says in the reddit thread.  The http://192.168.1.1/#/advanced/fwupgrade link works to get to an update option.  However, it doesn't accept the linked Frontier firmware images, and I can't find a binary firmware image for regular FIOS G1100s, just the source to the binaries that should be within the signed firmware image.

0 Likes
jonjones1
Legend

If you read the article it states not to use Frontier firmware.

i also told you the firmware is not necessary since the router does not use โ€œRโ€ band.

i will attach a screen shot showing the absolute last firmware update.

if the numbers are the same then you are at the most newest firmware.

image

glugglug
Enthusiast - Level 3

Looks like I already have the latest. 

0 Likes
jonjones1
Legend

@glugglug wrote:

Looks like I already have the latest. 


Glad it all worked out ๐Ÿ˜€

0 Likes
glugglug
Enthusiast - Level 3

BTW, I got it now delivering close to the 144Mbps WiFi, and got the internet light to go white when acting as a bridge, not a primary router. (I'm supposed to have 150, other routers actually get a bit above this).

The relevant settings for this trick:

  • static IP for the FIOS router LAN and WAN MACs configured in main router
  • IP of the bridged LAN ("Network (Home/Office)" manually set to the configured LAN static IP.
  • Route added - a normal bridge, or the old ActionTecs, does not require this step, but without it on the Quantum Gateway, devices connected through WiFi don't see the internet (while devices connected through ethernet do...):
    • Destination: 0.0.0.0
    • Gateway: IP of main router LAN side (in my case 192.168.2.1, probably 192.168.1.1 for most people)
    • Netmask: Ideally 0.0.0.0 but it won't let you enter it this way.  Enter 1.0.0.0 and it shows up as 0.0.0.0
  • Fireway IPv4 security: minimum (don't know that this actually matters)
  • IP address distribution: disabled- this one is critical as a bridge.
  • DNS server: No DNS server

And finally, the fun part, that makes it happy about the internet connection it sees in bridged mode and somehow faster.  A normal router would not have these items for bridged mode:

  • Enable the WAN connection but disable COAX WAN
  • Connect an ethernet cable from the WAN port to one of the LAN ports on the FIOS router, so it supplies the internet connection to itself.  Yes, really, **bleep**, tried sort of as a goof and it actually worked.
smith6612
Community Leader
Community Leader

@glugglug wrote:
  • Connect an ethernet cable from the WAN port to one of the LAN ports on the FIOS router, so it supplies the internet connection to itself.  Yes, really, **bleep**, tried sort of as a goof and it actually worked.

I'm surprised that didn't cause a loop on your network o.O. I'd be curious to see whether or not you have a high amount of TCN / STP traffic on your network with the WAN-to-LAN-to-self configuration.

0 Likes