Internet Speeds consistently slower than I'm paying for
Enthusiast - Level 2


Having read through a number of the recent posts with similar subjects, I feel a little sheepish for complaining about my speeds (my sympathies to the folks who can't even get 1 Mbps), but I'm not getting what I'm paying for. I have High Speed Internet Enhanced, which is advertised as 3.1 to 7.6 Mbps.

For the last few months, I have noticed a dip in the speeds that I get (judging by the inability to stream 240p videos without pausing every few seconds). It's pretty consistent, with periods during which the internet grinds almost to a halt.

I have conducted speed tests on:
A Windows 7 laptop (ethernet and wireless)
A Mac OSX laptop (ethernet and wireless)
A Windows XP desktop (ethernet)

making sure that all the other devices were turned off during the tests. They all reach download speeds of 2.6-2.7 Mbps, when they're feeling spry. The upload speeds are about 0.7 mbps.

Now, I know that 2.6 Mbps isn't terrible, and that's why I haven't complained about it for the last few months. However, I recently found out that Verizon is going to increase my price another 10%. If I'm going to pay $50 each month for internet service, I had best well be getting at least the MINIMUM speed advertised.

My router info is below.
Model: GT704-WG-B
Firmware Version: 30.20.2    
Gateway MAC Address: 00:26:62:1d:57:26
WAN IP Address:
Subnet Mask:
Gateway IP Address:
DNS Address #1:
DNS Address #2:

I've been through the customer service shuffle to no avail (they couldn't even find my info before transferring me, then informing me the office was closed, and disconnecting).

Anyway, this way I can lay out my case in full. Any advice or help would be very much appreciated!


1 Solution
Enthusiast - Level 2

The issue has been fully resolved by switching to Comcast Xfinity. I'm now getting 10X the speed and paying $10 less each month.
Thank you to the community members who took the time to respond to my post!

View solution in original post

11 Replies
Enthusiast - Level 2

Mine has slowed way down. I suppost to have 7 mbs but now have 1.3 mbs.

I'm so tired of Verizon not working correctly. For three years I never got to my true speed. I had, at least 5 techs out and they all told me it is fine. One even told me to get slower account....he said their lines were too old for 7 mbs.

Finally got a GOOD tech and he fixed the wire was broken inside insultation. He fixed it and I had 6.5 mbs after that. Great. It was a Verzion bad line.

Then I get a bill for $136.00 for fixing their own line. Went thru their Customer service..really bad service their also. Said I had to pay the money casue the Tech stepped inside my buildinhg. Called the tech and he told me that he did not bill me. It is common for the tech to run a ping test from inside the building. He talked to his supervisior and was told there was nothing he do to help..

So now I have 1.3 mbs and an over billing of $135.00.

People beware

Moderator Emeritus

Hi BigBrutal64

Your issue has been escalated to a Verizon agent. Please go to your profile page for the forum, and look in the middle, right at the top where you will find an area titled "My Support Cases".
There you will find a link to the private board where you and the agent may exchange information. This should be checked on a frequent basis as the agent may be waiting for information from you before they can proceed with any actions.

Customer Service Rep


Since we haven't heard back from you or received the form submission as requested in your private support case, it appears assistance is no longer required. If you need any future help with your Verizon service, please make a post here on the forums so we can assist.
- Joseph_VZ

Community Leader
Community Leader

To OP only:

Step one: Visit and post up the Traceroute the page shows, if you wish. Be aware that the final hop (bottom-most line of the trace)  might contain a hop with your IP address in it. Remove that line. What I'm looking for is a line that mentions "ERX" in it's name towards the end. If for some reason the trace does not complete (two lines full of Stars), keep the trace route intact.

Step two: Can you provide the Transceiver Statistics from your modem?

#1 After you log-in to the modem go to Status -> DSL Status

#2 Please post the info that is there.

Enthusiast - Level 2

I have the same problem, but I can't call Verizon because if I do, I will get "You have a service call in place" - we'll call you "Click".  You know that isn't very nice. 

Incidently, we were also having noise on the line that made it unuasable when it rained.  You won't be able to fix that one UNLESS you can troubleshoot it when it fails.  I can't see a way for that to happen AT all,  I need a means to call Verizon via another method, like mobile phone, and say the telephone line is broken RIGHT THIS instant.  Come fix it.

I suspect it will happen again.  We depend on phone service for a Personal Emergency Response System.

The acid test that I suggested was to take my troubleshooting modem, a Westell 2200 and connect it directly to the laptoop with a crossover Ethernet cable eliminating ALL inside wiring and even the DSL spiltter.   

Earlier tests inside using the Westell 2200, with the telco line disconnected at the NID revealed the modem reporting 2112 kbps.  That above test eliminates: a NID installed splitter that's less than a year old, a 7' RJ11-RJ11 patch and 4 connections on 110 punch down block.

My Normal modem is a Westell 6100 in Bridge mode running off of Power Over Ethernet.  My entire Network junk except one repeater is UPS backed up.

You can't even troubleshoot out of a wet paper bag,

At 4/13/13 12:09 PM I had a 278 ms ping with 0.23 mb/s up and 0.4 mb/s down for a 3 Mb/768 k service.  this has been going on for over two weeks.  This is UNACCEPTABLE!

You guys keep blaming it on my network, your modem (THEY are OLD you say) or inside wiring which is now ludicrous based on the below test. and your customers know more than the professionals. 

It's not the first hop: Not first hop

The first hop is what I define to be my IP address from outside from

Here is the hops causing the problem in VERIZON's Network.

This is the full traceroute to www.pingplotter,com

The above pics are located in this CLOUD as well as TXT file with the historical data.  Those files are at the top of the page.

Hopefully tomorrow, I'll have a TXT  file that has  24 HR monitoring every 5 minutes.

CLEARLY this is Verizon's problem.  Clearly I found the right tool (It's a pay product under evaluation).

Windows traceroute WILL NOT WORK.  It never has on verizon's Network.

Thank you!

Enthusiast - Level 2

Here's the info from giganews:

traceroute to {edited for privacy}, 30 hops max, 60 byte packets
1 ( 0 ms 0 ms 0 ms
2 ( 0 ms ( 0 ms 0 ms
3 ( 0 ms ( 0 ms 0 ms
4 ( 48 ms ( 0 ms 0 ms
5 0.xe-12-0-1.RES-BB-RTR1.ALTER.NET ( 0 ms 1 ms 0 ms
6 ( 9 ms 9 ms 9 ms
7 ( 12 ms 12 ms 12 ms

traceroute to {edited for privacy}, 30 hops max, 60 byte packets
1 ( 0 ms 0 ms 0 ms
2 ( 174 ms 174 ms ( 174 ms
3 ( 0 ms ( 0 ms ( 0 ms
4 ( 85 ms 85 ms ( 10 ms
5 ( 76 ms ( 85 ms ( 76 ms
6 ( 85 ms ( 81 ms ( 81 ms
7 ( 82 ms ( 82 ms ( 82 ms
8 0.xe-10-3-0.BR2.NYC4.ALTER.NET ( 85 ms 85 ms 0.xe-8-3-0.BR2.NYC4.ALTER.NET ( 82 ms
9 ( 86 ms ( 93 ms ( 86 ms
10 ( 98 ms 98 ms 97 ms
11 ( 98 ms 93 ms 93 ms

I apologize if you didn't need both traces, but I thought I'd include it just in case.

And here is the DSL status info from the router:
DSL Status
VPI: 0
VCI: 35    
DSL Mode Setting: Auto    
DSL Negotiated Mode: G.DMT    
Connection Status: ShowTime    
Speed (down/up): 3360/736
ATM QoS class:   UBR
Output Power (Downstream/Upstream): 11.9/15.9
Attainable Rate (Downstream/Upstream):     6816/836
HEC Errors (Downstream/Upstream): 9852/0
OCD Errors (Downstream/Upstream): 415/0
LCD Errors (Downstream/Upstream): 0/0
SNR Margin (Downstream/Upstream): 14.8/9.0 dB
Attenuation (Downstream/Upstream): 55.0/31.5 dB

I don't know enough about this stuff to blank out any info that shouldn't be shared online, but I don't see any IP addresses or anything.

Thank you SO much for taking the time to help me!


PS. What is with people taking over everyone else's posts? It's unfortunate that the forums are a sort of stand-in for official customer service, but really, it makes things even more complicated.

Enthusiast - Level 1

Wow I have this exact problem. They supposebly troubleshooted it last week and I was getting 8Mbps but now it's fallen back to 1-3Mbps and I get over 500ms when I ping test. So dumb, I'm starting to regret switching over from timewarner.

Community Leader
Community Leader


#1 An original or very old style NID with a spark gap and ground wire can even get spiders in it that could cause an issue. Inspect the NID first before thinking of changes or wiring.

Running a good quality wire CAT5, no need for CAT6,  directly to the NID for the DSL modem jack may help. That is what I had done with mine. Depending on the number of loads or amount of wire in the house could also cause issues. But if the user's signal quality is not being pulled low due to a wiring issues, it would usually indicate a problem elsewhere. Unless there was noise being picked up on the premises wiring. Wire DSL directly to the NID and install a filter there for all other in house wiring may help. There used to be available what was called a NID Filter, and I am sure you can still get them.

Ideal Connection if house wiring is an issue, or very old, and lengthy. Install a filter / splitter at the NID.

Run CAT5 directly to the NID location, and install a dedicated jack for the DSL modem.

Remove all in house wiring from the NID.

Connect piece of CAT5 from the NID to the filter / splitter input

Connect all existing phone lines to the phone side of the filter output.

Connect the new DSL CAT5 directly to the NID before the filter / splitter, or to the DSL side of the filter / splitter, depending on the device purchased.

This will take all the existing premises wiring out of the picture unless there is a short circuit or excessive load somewhere in the house.

At this point all the single filters could be removed because the DSL is filtered at the NID.

#2 You can test outbound to Giganews. But giganews has/had a test that will check your inbound connection from their servers to you.

I heard from another user that

Giganews is being watched very closely because of multipart binaries, and pirated material. MP3s and Video Content. 7 years ago you could get 10-20 MP3 albums in a single day, and that was with a 15/5 fios connection. So they started providing an encrypted connection service for an added fee. I have not messed with news groups for a very long time. Now with deep packet inspection, and other enforcement, I would not even think of it. No news I want there. But there may be content that people want? They may even be checking and limiting speed from that domain. Never tested. But let me see. It looks as if reverse trace routes and speed tests are being blocked by Verizon from Giganews to my router.

        Reverse Traceroute


        traceroute to *.*.*.*, 30 hops max, 60 byte packets
        1 ( 0 ms 0 ms 0 ms
        2 ( 0 ms 0 ms ( 0 ms
        3 ( 0 ms 0 ms ( 0 ms
        4 ( 28 ms ( 40 ms ( 28 ms
        5 ( 41 ms 41 ms ( 13 ms
        6 * * *
        7 * * *
        8 * * *
        9 * * *
        10 * * *
        11 * * *
        12 * * *
        13 * * *
        14 * * *
        15 * * *
        16 * * Max number of unresponsive hops reached (firewall or filter?)

#3 Have the provider run a local loop test to see if any problems are indicated. If there are, then they could run the test with everything in the house disconnected, except the new DSL modem connection. If issues are still indicated, then the DSL provider needs to make connections on the local loop. Another user told me that they had issues when it rained, and it was because construction had left a splice box open on a line somewhere.

Enthusiast - Level 2

Been there done that.

The NID guts were replaced about a year ago.  New protector and DSL filter/1/2 ringer module.  A very nice design.  Easy to lift the telco signals to the inside.

I have two modems.  A Westell 2200 used for troubeshooting and is configured for direct connect.  A 6100 used in bridge mode.  I can easily swap both modems.  The 6100 runs off a UPS from POE.  The 2200 cannot even when testing.

Slow speeds exist on both.

Nearly all the commonalities can be eliminated such as power supply, DSL cord, Ethernet crossover cable, modem etc.

With the 2200 modem DIRECT CONNECTED at the NID the problems percist.  This eliminates EVERYTHING inside the premesis.

24 hour recording every 5 minutes says the situation doesn't improve.

In any event, the inside connection is very pristine for the DSL side.  About 3 feet of an 8 conductor CATx wire from the DSL termination to a 110 bridgeing block.  about 10 inches of wire to a 110 RJ11 jack.  A 10 foot patch cord (now CAT5E rated) to the DSL modem used.

The premesis wiring cannot be my problem.

The NDT test servers indicate conjestion as a possible cause.

Now, the one thing that would help me is to understand the path of a packet when a modem is in bridge mode.

Suppose I ping my public IP from the premise side.  My thinking says that that packet travels the phone line as DSL.

Now, suppose I reverse ping/trace route.  My thinking is that the packet does not travel the DSL modem side.  It basically stops at the public IP address server which is located about 40 miles away.

Pings from inside the premisis generate 2 mS delays (wireless LAN) whereas outside they are much longer.  As high as 500 mS.

Community Leader
Community Leader

@K_I_S_S wrote:

Been there done that.

The NID guts were replaced about a year ago.  New protector and DSL filter/1/2 ringer module.  A very nice design.  Easy to lift the telco signals to the inside.

Sorry, that message was to @iamihop

Enthusiast - Level 2

The issue has been fully resolved by switching to Comcast Xfinity. I'm now getting 10X the speed and paying $10 less each month.
Thank you to the community members who took the time to respond to my post!