Just gotten Fios but the router isn't working like it supposed to
Chemilla
Enthusiast - Level 1

so i just gotten Fios almost a week ago 300/300. I have my desktop plugged in through ethernet through the Fios router and the YouTube or other streaming services are kinda slow loading. I brought new cables all cat 7 and still didn't make a difference. I took the router out of the equation and everything seem to working fine straight from the ont. I reset the router every time but evenly it just stops working. I had tech look at it and they say it fine but I'm also a technician and this is not okay. DO anyone has a an idea or should i just bring my own router

0 Likes
9 Replies
Cang_Household
Community Leader
Community Leader

If you have considered you need new cables, have you checked whether you need new network interface cards or, better yet, new computers? Intel made revisions to their NICs and cards made after circa. 2021 do not need to go through the adjustment given by gs0b.

Sometimes the NICs is part of the computer motherboard. To get an updated and better NIC, a new motherboard will be required.

Chemilla
Enthusiast - Level 1

So just do a new build....that's ridiculous 

0 Likes
gs0b
Community Leader
Community Leader

Does your computer have an Intel Ethernet chip?  If so, go into Device Manager (Windows), and disable both IPv6 TCP checksum offload and IPv6 UDP checksum offload.  That'll fix the problem.

Chemilla
Enthusiast - Level 1

i did that already and it didn't work

0 Likes
gs0b
Community Leader
Community Leader

@Chemilla wrote:

i did that already and it didn't work


Did what?  There are several suggestions in this thread, so it's not clear which one you tried.

Have you confirmed what Ethernet chip is in your computer?  Can you share?

You also haven't mentioned the router model, that can be helpful.

Remember, all we know is what you tell us.  More details are better.

Chemilla
Enthusiast - Level 1

router model :CR1000a

ethernet: Intel I218V
I have made new cables cat 7.
I have updated my network drivers
i even put a switch in-between and that didn't work. 
I disabled upd ipv4 offload
The only thing that worked was to eliminate the router from the network.

0 Likes
gs0b
Community Leader
Community Leader

Okay, that's an Intel chip with the IPv6 checksum offload issue.  See this Intel notice form 2017 that details the problem:

https://www.intel.sg/content/www/xa/en/download/19174/disabling-tcp-ipv6-checksum-offload-capability...

You need to disable both IPv6 TCP and IPv6 UDP checksum offload.  Your comment said you disabled IPv4 checksum offload, which is not related to this problem.  If that was not a typo, turn it back on.  The properties you want to disable appear in the Windows Device Manger as:

  • TCP Checksum Offload (IPv6)
  • UDP Checksum Offload (IPv6)

If you'd like to do further diagnostics to determine if this is the issue (I think it is), here are additional steps you can use to verify the problem.  If you do these while IPv6 checksum offloads are ENABLED and the problem goes away, it's consistent with this issue.

  • Go into the router settings and turn off IPv6.  I don't have a CR1000A, so I don't know exactly where the setting is.  If it's similar to other Verizon routers, it's in Advanced->Routing/IPv6.
    Note this is not a recommended long term approach, as IPv6 is used by more and more internet resources.  There eventually will be resources you can't reach without IPv6.  This is only a debugging method to confirm the Intel Ethernet chip is involved in the issue.
  • If the computer has WiFi, test with it.  WiFi chips are not subject to the checksum offload bug.
  • If you have other computers with Ethernet that don't use Intel chips, check them.  A USB Ethernet dongle is a quick way to test, as they usually have non-Intel chips.
  • If you have other computers with WiFi, test those.  Again, this problem does not occur on WiFi.

Note that if you don't have Verizon set-top-boxes, you can easily use whatever router you like.  The only "disadvantage" of this is Verizon support stops at the ONT.  If you're okay managing and debugging your own network, this shouldn't be a problem.  Just keep a Verizon router around in case you run into a Verizon issue later so you can plug it in to work with their support.

Cang_Household
Community Leader
Community Leader

No, don't turn off IPv6. IPv4 is a legacy protocol and may be disabled in the future.

Relying on a legacy protocol when a newer protocol is available is looking for more incompatibility.

gs0b
Community Leader
Community Leader

IPv4 isn't going to be turned off anytime soon.  Due to IPv4 only devices such as older IoT nodes, printers, old office equipment, and other ancient systems that should be but aren't upgraded; IPv4 can't be turned off today.  Maybe sometime in the future, but not yet.

Heck, it took Verizon way more years than it should have to enable IPv6. 

Now, there are some modern services that are IPv6 only, but I'm not aware of any that are intended for use by the general public.  Until Amazon, Facebook, Google and other mass-consumer sites go IPv6 only, there is very little risk to the typical internet consumer.

Turning off IPv6 in the router for diagnosing problems is a valid use case.  I don't recommend leaving it off, as IPv6 will be need in the future, as I noted in my post.  We just don't know how far away that future is.

OP: Let us know the results of any of the suggestions I provided above.