Lacrosse Weather Station will not connect to Wifi
dragracer775
Newbie

I have a Lacrosse Weather Station C83100 and it will not connect to my Gateway Router. It is only supported on 2.4 Ghz Wi-Fi.  My Iphones are connected through the router on 2.4 Ghz so I know the router is working.  I know the weather staion is working because I took the device to my daughters house who also has a Gateway Router and it connects there. I need some advice please

0 Likes
Reply
4 Replies
EricE2
Enthusiast - Level 1

Most LaCrosse Weather Stations have pretty awful wifi chips - and supporting 2GHz only is a real pain too since most wifi accesspoints/routers are configured with the same SSID on both the 2GHz and 5GHz radios.  

If you are using an app on the phone to join the weather station to wifi, the phone and the device have to be on 2GHz together, and the easiest way to do ensure that is either set up a dedicated SSID that is 2GHz only for your IoT things, or temporarily disable the 5GHz radio while you are joining the weather station to the wifi.  Once joined, you can turn the 5GHz back on.  Which is easier to do depends on what options you have with your Wifi access point.  Even then it can still be problematic - I'm having a heck of a time getting mine joined back with my Unifi AP and I think I'm going to have to enable a bunch of the really old/slow b/g/n stuff to at least get the thing joined again.

(yes this is an old post, but I landed here via search so other will too)

rayandanja3
Newbie

Here in 2023 with same problem...

Quantum Gateway has separate 2.4 and 5 GHz options on my phone to pick from, but the 2.4 GHz one doesn't work.

Fixed by enabling Guest Network  in the Quantum Gateway.  That looks like it is 2.4 GHz only.

0 Likes
Reply
kh-taylarie
Khoros Partner
Khoros Partner

Due to the age of this thread, it will be locked in order to keep discussions current. If you have the same or a similar question/issue we invite you to start a new thread on the topic.

0 Likes
Reply
jonjones1
Legend

I have no idea about your weather station. I am going to assume you have the ability to access the settings on it? If so I would try removing all the prior connections. Then manually search for your network SSID (name) then enter the password exactly.

you could access the Quantum router and change the SSID and password and then reconnect your devices. Just an idea.