Login problem with MI424WR router

I am trying to login to my router, but am having password trouble.  I used admin for the name and tried password and my serial number and several other things for the password.  I noticed that when I type in the password field, several asterisks are put in for every letter I type.  Almost like there's an echo turned on, but it is not always the same number of *s.  None of my login attempts work, I assume because I can never actually get the right password into the field.  I have tried copy and paste from notepad, but that still puts in about 15 *s for an 8 letter password.  I did a hard reset.  No change.  I use Chrome browser, but tried in IE.  No change.  I am using Windows Vista, SP2.  I am doing this wireless also, not via ethernet cable.  Any ideas?  Thx.

Re: Login problem with MI424WR router
Master - Level 2

You can ignore the number of characters coming up.  Thats just a "security" feature designed to confuse anyone who might watch you as you try and enter a password.

If you did a hardware reset on the MI424WR then the password is probably reset to "password".  All lower case.  It should then ask you to pick a new id and password for Administrating.