MI424WR DHCP server problem
Enthusiast - Level 1

Frequently, a device on my network is unable to get a DHCP address from the router.   Things that are connected to the Internet are fine, but say I come home from work and my iPhone connects to the wireless, it won't (it will display the SSID of my network, but fail to connect).   A laptop I use at work also won't get an address over the wired network.   However, Vonage is working just fine.    So, power off the router for a few seconds and after power on, everything is fine.

Any suggestions?   

Re: MI424WR DHCP server problem
Master - Level 2

Have you tried to factory default the router to start?  I use a multitude of devices without issue including a work laptop on the wired and wireless and my IPHONE, ITouch, Wii, XBOX, etc.

For the wireless you may want to consider changing the security from WEP to WPA2.  That is what I use without issue.  As far as the wired connection, that doesn't make sense so factory default the router and see if that helps.


Re: MI424WR DHCP server problem
Enthusiast - Level 1

I have the same problem.  What I have done as a temporary workaround is to configure the alternate settings on my adapter.  This way, when DHCP times out, it uses this (valid) IP instead of the APIPA (169.254.x.x) address.  It works for me, which also proves its a DHCP issue and not a problem with the connection itself.

(picture for example only - IP is invalid)


Re: MI424WR DHCP server problem
Enthusiast - Level 3

M-Crowley: I'm having the same problem but I don't really understand your temp solution.  What values are you putting in there?  I'm not asking for your specific values, but what I should be putting in on my side.  That is, what info should I be looking for to put in this table?



Re: MI424WR DHCP server problem

If wireless devices are having the problem connecting and getting a DHCP, then it could be from WiFI interference.

open a browser, and go tohttp://

user name is admin.  and the password is most likely the serial number found on the service tag of your VZ router unless you changed it. Once you login succesfully, go to the top and hit wireless, then on the left basic security.   then go to option 3 which is channel  1, 6 and 11 and are the only channels you should try.

So it will likely be set to auto, change it to 11 and put the check for keep settings even after reboot (Directly under the channel) and then hit apply.  after you hit apply,  test your connection out, if you notice a difference, leave it like that until the problem happens again, and if it happens again, go back into the router, and try channel 6,     test it out.  and then finally 1 if the first two don't work.

Also take a look at page 2 of Actiontec's Wireless PDF File.  It gives you some idea's with regards to position and orientation of where the router sits and how it can best be positioned for maximum coverage.

Also take a moment to look at Actiontec's article, re: How to improve wireless networking with the MI424WR Verizon FiOS Router

Give it a shot it may help.