Macbook Pros suddenly can't stay connected to Gigabit Wifi
TMC15
Newbie
Upgraded internet service to Gigabit speed with Fios router and wifi extender late June. All home internet devices connected and stayed connected without problem until today.  Both Macbook Pros (2016/2019) can no longer stay connected to wifi. At this point both laptops are unusable because the wifi keeps dropping out. However iMac, iPhone, Ipad, as well as non-Apple devices can all stay connected.  
 
I have made no changes to either the Macbooks or the network since the new service was installed.
 
Please help. I'm at my wits end here and need these laptops to connect in order to work from home.  Thank you!
0 Likes
Reply
1 Solution
jonjones1
Legend

I would simply unplug the router and count to 30 and plug it back in.

while this is booting up make sure the problem devices are totally off. After boot up then turn your Macs back on and see if they connect.

sometimes Verizon fios will do an update and not tell you, then with the settings change it goes haywire until a restart.

also make sure the self organizing network is not set to on (SON) this also can cause terrible issues with wifi connections.

View solution in original post

3 Replies
LawrenceC
Moderator Emeritus

As this thread is now two years old, it will be locked in order to keep discussions current. If you have the same or a similar question/issue we invite you to start a new thread on the topic.

0 Likes
Reply
jonjones1
Legend

I would simply unplug the router and count to 30 and plug it back in.

while this is booting up make sure the problem devices are totally off. After boot up then turn your Macs back on and see if they connect.

sometimes Verizon fios will do an update and not tell you, then with the settings change it goes haywire until a restart.

also make sure the self organizing network is not set to on (SON) this also can cause terrible issues with wifi connections.

nyhunter77
Newbie

SO, this helps for a few days, 2 or 3, but then the issue comes back. Has anyone tried anything else? settings on the router itself?

0 Likes
Reply