Netflix blocked
BangMyHead
Enthusiast - Level 1

I have been having troubles with Netflix with EVERY device in my home.  All other internet sites work fine but not Netflix.  Yet, I can get Netflix using cellular (so Netflix is up).  I saw other posts on renewing DHCP lease and turning router firewall off but these did not help.  I did a Tracert check and found all devices in my house were getting a one-hop to an Amazon.aws site where it ended. 

I called tech support and they told me I had to upgrade my router for another $13 a month to allow Netflix...nope, that makes NO sense since every other site works.  The tech actually encouraged me to switch to another ISP as a solution since I would not upgrade!  Seriously?  I ended the chat and will seriously explore that option based on that level of customer service.

I fixed the problem by deselecting auto-DNS in the router and I gave it a primary of Google (8.8.8.8) and secondary of OpenDNS (208.67.222.222).  Boom - Netflix is back in action.  In other words it appears that Verizon's DNS is blocking Netflix.

1 Solution
CRobGauth
Community Leader
Community Leader

What were you getting when trying to access Netflix?

I use Auto DNS and watch netflix all the time.

View solution in original post

3 Replies
Edg1
Community Leader
Community Leader

Verizon DNS in PA area are also working for Netflix. 

CRobGauth
Community Leader
Community Leader

What were you getting when trying to access Netflix?

I use Auto DNS and watch netflix all the time.

BangMyHead
Enthusiast - Level 1

I used to watch Netflix all the time too.  I was using Laptop, PC, iPad, phone on wifi, Smart TV...nothing worked on Verizon DNS despite many reboots, troubleshooting, etc.  Until I changed the DNS to Google.  Hmm.