New Gigabit Has connection issues
roads722
Newbie

     I upgraded from 2 .4GHz to the new Gigabit service as pictured. My problem is that when connected through the ethernet port on the desktop, everything is slow loading. YouTube freezes and connection is lost often. Then I switch to Wi Fi the situation clears up somewhat. On my laptop, you tube and sometimes freezes. All after having this new service installed.  As you can see by the Photo, these are the settings when installed. 

Present SetupPresent Setup

 

Also, I ran a diagnostic on my laptop and cane up with the message pictured below.  My question is what settings should I try? I'm unsure at this point what to do because I'm unfamiliar with this stuff and don't want to cause further issues. I'm hoping it's a simple fix and not have to get support involved. 

Screenshot 2023-04-04 225408.jpg

Labels (1)
0 Likes
1 Solution

Correct answers
Re: New Gigabit Has connection issues
smith6612
Community Leader
Community Leader

This is probably an issue with IPv6. Try this first:

Go into the the Device Manager on your PCs and disable IPv6 Checksum Offload for TCP and UDP. The steps are:

  1. Right click the Start Menu button
  2. Open the Device Manager
  3. Open Network Adapters. Find your Network Adapter (Intel I211-V for example) and double click on it
  4. Click the Properties Tab.
  5. Find "IPv6 Checksum Offload (TCP)" and "IPv6 Checksum Offload (UDP)." For each option, set it to Disabled.
  6. Click OK
  7. Try your speed tests and services again to see if they work any better.

Other Ethernet devices may also be affected, so look for similar settings if you use Realtek, Qualcomm, Aquantia, etc Ethernet. You may have similar options to set on your Wi-Fi  Adapters especially if they are Intel.

If this doesn't fix the problem, the new CR1000A and G3100 routers come with IPv6 enabled. You can try disabling that on the router itself to see if your streaming problems disappear.

By the way. You may want to enable 6Ghz if you have 6Ghz capable devices. Just be aware this will force your network to use WPA3 Security, which not all devices support.

Regarding the message about USB 3.0 and 2.4Ghz Wi-Fi. This is actually a true statement. When a USB 3.0 device is near a 2.4Ghz transmitter, or if a USB 3.0 device has poor shielding, the frequency at which USB 3.0 operates at can cause interference on the 2.4Ghz band, and this can severely impact 2.4Ghz Wireless performance.

View solution in original post

Re: New Gigabit Has connection issues
smith6612
Community Leader
Community Leader

This is probably an issue with IPv6. Try this first:

Go into the the Device Manager on your PCs and disable IPv6 Checksum Offload for TCP and UDP. The steps are:

  1. Right click the Start Menu button
  2. Open the Device Manager
  3. Open Network Adapters. Find your Network Adapter (Intel I211-V for example) and double click on it
  4. Click the Properties Tab.
  5. Find "IPv6 Checksum Offload (TCP)" and "IPv6 Checksum Offload (UDP)." For each option, set it to Disabled.
  6. Click OK
  7. Try your speed tests and services again to see if they work any better.

Other Ethernet devices may also be affected, so look for similar settings if you use Realtek, Qualcomm, Aquantia, etc Ethernet. You may have similar options to set on your Wi-Fi  Adapters especially if they are Intel.

If this doesn't fix the problem, the new CR1000A and G3100 routers come with IPv6 enabled. You can try disabling that on the router itself to see if your streaming problems disappear.

By the way. You may want to enable 6Ghz if you have 6Ghz capable devices. Just be aware this will force your network to use WPA3 Security, which not all devices support.

Regarding the message about USB 3.0 and 2.4Ghz Wi-Fi. This is actually a true statement. When a USB 3.0 device is near a 2.4Ghz transmitter, or if a USB 3.0 device has poor shielding, the frequency at which USB 3.0 operates at can cause interference on the 2.4Ghz band, and this can severely impact 2.4Ghz Wireless performance.