Possible router bug
Contributor - Level 1
Hi all,
From my previous post, I have done a lot more testing and after a power outage, the upload is again capped at 200-300mbps.  Incase anyone runs into this issue, the workaround is to disconnect the WAN (ethernet) cable from the Verizon router (CR1000A) and plug it back in, then speeds are restored (back to 900mbps/900mbps).
I have tried 5 different ethernet cables, so I do not believe it is related to the cable.  Also, when I connect directly to the ONT, the issue is not present.  As this Verizon router (CR1000A) is new,  it may be a bug in the firmware.   Once the issue is "fixed", it does not recur unless there is a loss of power.  Incase anyone else runs into this issue, it may be worth noting here, thanks!
Prior post: FiOS gigabit service: Down: 800-900mbps, uplink capped at 325mbps:
Labels (1)
8 Replies
Contributor - Level 1
Someone else has just reported this issue as well:


Their fix was to go to a previous Verizon router and everything was back to normal.

if enough people report this issue, VERIZON may have be able to look at the firmware more closely.
Community Leader
Community Leader

Did you use an older VZ router on the same circuit before?

Some times, the upstream GWR would not unleash all the subscribed speed unless seeing a specific MAC address. This behavior is anecdotal at best, but does worth a try by changing the MAC address of the WAN port on the CR1000A through software.

Contributor - Level 1

Did you use an older VZ router on the same circuit before?

I had not, this was a new installation, although the prior people that lived here did have the ONT already attached to the side of the house.

I had not heard of that issue previously but I will keep it in mind for the future, thank you.

I have attached the old VZ Router (black G1100 Quantum Gateway) that was used at a different address 3-4+ years ago and it is consistent speeds (900/900 mbps) even across reboots/power cycles without any issue.

Although it is part of the plan and "included" in the service cost, the new Verizon CR1000A router has a serious bug in the firmware and unless you check for these things, most people probably would not even notice the degradation in upload performance.  CR1000Ahttps://www.verizon.com/support/verizon-router-cr1000a/


ISSUE: For reference / Verizon:
This router has a serious bug/issue that, when power is lost and restored, the maximum uplink speed is around 200-300mbps on a Gigabit plan:  Verizon Router (CR1000A)

Multiple other people have experienced the same issue in the dslreports forum post, proof:



My status as of June 24th, 2023:

- I have reverted back to the old Verizon router (G1100) and things are working properly again even after a power cycle.


Community Leader
Community Leader

Yeah I heard you.

Could you copy the G1100's MAC address to CR1000A's WAN port and test again?

Contributor - Level 1

Hi Cang, just to confirm before proceeding:
1. Obtain the Verizon G1100's Broadband MAC address from -> System Monitoring -> Broadband MAC Address
2. Login to the Verizon CR1000A and go to Utilities -> MAC Cloning and pop that in there and click Apply and then try to reproduce the issue?

FYSA: The Verizon Router (CR1000A) provided as part of the FiOS installation did appear to be new, it came in the original box was plastic wrapped, etc (never used before).

I did review the syslog messages and I never saw below 1000mbps (so the physical negotiated speed is good)-- do we think this could be related to a policy issue with respect to traffic shaping that Verizon sends down with respect to available uplink bandwidth?

Jun 23 17:48:22 localhost user 2023 Jun 23 17:48:20 netifd: [WAN.6][SYS] WAN link up, 1000 Mbps full duplex
Jun 23 18:47:08 localhost user 2023 Jun 23 18:47:06 netifd: [WAN.6][SYS] WAN link up, 1000 Mbps full duplex (this is when I disconnect and re-connect the WAN ethernet cable and then I see upload connectivity return to normal speeds)

Questions for Verizon regarding the CR1000A:
1. Why is only the upload affected?
2. Why does the issue present itself after a power outage? (I only saw this issue after had some work done with the electrical system here where the power had to be shut off)
3. Why does unplugging the ethernet cable from the WAN port and plugging it back fix the upload performance issue?
4. Why does this affect multiple users(?) on DSLreports-- this is not an isolated incident.
5. Why does using a G1100 router from ~3-4 years ago not suffer the same issue after a power outage?
6. When running the Verizon speedtest, does this run it from the ONT or from the Verizon router?
- When the issue was occurring, the Verizon speedtest *always* reported normal speeds but every other speedtest tool reported ~200mbps upload. FiOS support noted no issue on their end, that is why I am wondering, is the test run from the ONT? If so, that does not accurately represent most users will see as they are using a Verizon router (unless directly connected to the ONT).


Community Leader
Community Leader

Could you disclose the computer model you are running the test?

I need to see whether this issue is IPv6-Intel incompatibility related.

Contributor - Level 1
Hello, ONT -> FiOS (CR1000A)

From the FiOS router, all exhibit the same issue:
-> Tested to Intel 82574L
-> Tested to Intel X550-T2
-> Tested to Wi-Fi (Qualcomm/iPhone) (200mbps instead of 600-700mbps)

Remove CR1000A and connect ONT directly into my PC (X550-T2) and no issues.

8/14/2023: ONT -> G1100, no issues at any point in any scenario tested so far.

Something similar is happening to me as well.

Recently made a change of service tier from an ancient 75Mbps to 1Gbps plan.  Had the G1100 router that rarely gave any problems.  On the date that Verizon upgraded the service, I was already pushing in the 300s down  and 100s up, a major upgrade from the 80/90 I was used to; I figured their new CR1000A would take the numbers even higher.  it did anything but that.

Verizon's router speed test shows expected results 900/800+, but the device speed tests are all over the place.  Sometimes I barely get even 30 down and I'll have 200 up... I've tried this over Wifi (6E disabled) and ethernet with the same exact results.  I disabled IPv6 the moment I set up the router without any positive results.

Help appreciated,