Printer & file sharing not working with new Quantum G1100 router
rocktman1
Enthusiast - Level 1

I've had an Actiontec MI424 router ever since I started with FiOS maybe 5 -6 years ago. It works. I had printer & file sharing set up so my wife could use my USB only Epson printer & allowed her to access all the pictures on my computer. We received a Quantum G1100 router & I just got around to swapping the routers yesterday.

The initial installation went w/o a hitch. Or so it seemed. Both computers got IPs (the same as with the old router, I believe) & went online. My tablet was able to connect wirelessly to the router & I made some other adjustments to security. However, printer & file sharing were a no-go. I can ping my wife's PC from mine & I think I pinged mine from hers. She's using the Windows firewall, but I'm using Zonealarm (same exact setup as with the MI424 with no changes). My wife went ballistic (as she usually does when it comes to her computer) so I swapped the routers again & we're now back on the MI424. Printer & file sharing work once again. To recap: Sharing works with the old router. but not the new one. What am I missing?

0 Likes
1 Solution
CRobGauth
Community Leader
Community Leader

possibly a firewall setting in router.

Quantum router is more locked down than previous models

View solution in original post

7 Replies
CRobGauth
Community Leader
Community Leader

possibly a firewall setting in router.

Quantum router is more locked down than previous models

rocktman1
Enthusiast - Level 1

Thanks for the reply, CRobGauth. I thought of the firewall as well. It's set on typical, but will try it on low over the weekend.

0 Likes
rocktman1
Enthusiast - Level 1

CRobGauth, you came closest to the solution (it wasn't the router's FW though) so I gave you Kudos.

I was determined to find a solution if a reasonable solution could be found. I found it this morning. One thing I had wrong in my initial post was that I could ping my computer from my wife's. That turned out to be incorrect; I couldn't. Paying more attention to that than I had, I started looking at the multiple firewalls. I put the G110's firewall on low, but that didn't fix it. Then I went into my Zonealarm firewall & made sure PING was enabled (it was). I added my wife's IP to the Trusted zone, but that didn't fix it. Finally, I changed the ZA's Public zone to medium (something I did with some amount trepidation) & that appears to be the answer. Printing & file sharing are once again working on my wife's computer. I'm still puzzled by the original ZA FW settings blocking my wife's computer with the G1100, but not the MI424. I want to thank everyone who responded to my issue.

0 Likes
lasagna
Community Leader
Community Leader

Three items to check ...

1. Make sure that your computer hasn't reclassified the network as a new network and not made it a "home" network.  Since you changed the router, while the IP network is the same, the firewall may be recognizing that the access point MAC changed and triggered a new network configuration for the firewall.   Easiest way is to turn off the firewall on both systems and see if printing works.

2. Is your PC wireless or wired?  If it's wireless, make it wired into the router temporarily and see if the problem goes away.  If so, then the new router may have "Wireless Privacy" enabled.  Not sure how or if you can configure this on the router directly as I don't have that model -- but essentially, it's a feature common on public wifi which prevents two clients on the same wireless network from seeing one another directly -- to lower the risk of individuals trying to hack into your computer when you are on the local coffee shop wifi.  For a home network, wireless privacy must be disabled (this is not the same as secured -- i.e. wifi pasword and encryption) in order for devices to see one another.

3. Make absolutely certain both systems have the same IP address as previously.  Power both systems down, bring up your system first and then your wife's.  If you don't have the same IP address as previously, you may need to change the port configuration in your wife's system so that it can find your computer.   It's necessary to have both systems powered down in order to clear the ARP tables (you can do this on the command line as well, but it's cleaner to have you just reboot).

rocktman1
Enthusiast - Level 1

@lasagna wrote:

Three items to check ...

1. Make sure that your computer hasn't reclassified the network as a new network and not made it a "home" network.  Since you changed the router, while the IP network is the same, the firewall may be recognizing that the access point MAC changed and triggered a new network configuration for the firewall.   Easiest way is to turn off the firewall on both systems and see if printing works.

2. Is your PC wireless or wired?  If it's wireless, make it wired into the router temporarily and see if the problem goes away.  If so, then the new router may have "Wireless Privacy" enabled.  Not sure how or if you can configure this on the router directly as I don't have that model -- but essentially, it's a feature common on public wifi which prevents two clients on the same wireless network from seeing one another directly -- to lower the risk of individuals trying to hack into your computer when you are on the local coffee shop wifi.  For a home network, wireless privacy must be disabled (this is not the same as secured -- i.e. wifi pasword and encryption) in order for devices to see one another.

3. Make absolutely certain both systems have the same IP address as previously.  Power both systems down, bring up your system first and then your wife's.  If you don't have the same IP address as previously, you may need to change the port configuration in your wife's system so that it can find your computer.   It's necessary to have both systems powered down in order to clear the ARP tables (you can do this on the command line as well, but it's cleaner to have you just reboot).


Thanks for the reply. First, both computers are wired. I intend to retry the G1100 over the weekend & to lower the firewall settings. I'll be sure to verify the IP addresses are the same with both routers.

0 Likes
schinfchin
Enthusiast - Level 3

I agree with most of what the others said.

Just to add,I see that it's a print server setup with your computer as the server. Both problems, your wife's inability to view photos and inability to print has to do with her computers inability to detect your computer.

I assume your computer can print OK? Yes? If so, go to your wife's computer, try add a local printer, and see if her computer can detect the Epson hooked up to your computer in the network. I assume it is checked off as shareable on your PC. If not, follow the suggestion of others to check the firewall, privacy settings etc., till your wife's computer can detect.

At first glance, with the print server setup, and your computer can print, IP addresses is not the big issue.

0 Likes
rocktman1
Enthusiast - Level 1

@schinfchin wrote:

I agree with most of what the others said.

Just to add,I see that it's a print server setup with your computer as the server. Both problems, your wife's inability to view photos and inability to print has to do with her computers inability to detect your computer.

I assume your computer can print OK? Yes? If so, go to your wife's computer, try add a local printer, and see if her computer can detect the Epson hooked up to your computer in the network. I assume it is checked off as shareable on your PC. If not, follow the suggestion of others to check the firewall, privacy settings etc., till your wife's computer can detect.

At first glance, with the print server setup, and your computer can print, IP addresses is not the big issue.


Thanks for the reply. If her computer can ping my computer & mine can ping hers then both computers see the other, which I will verify over the weekend. Yes, my computer can print. Her computer could not see the printer on my computer with the G1100 & it is configured as shareable. I will be retrying the G1100 over the weekend.

0 Likes