Router G3100 Port and port forwarding
Fiosusr
Enthusiast - Level 2

On my previous Tplink router setuo, I was using port forwarding to access individual surveillance cameras, remotely,  while traveling. I am getting ready to setup that to see if I can really continue to use G3100.

Are others using port forwarding successfully on this G3100 router? I would appreciate any insights into this. 

0 Likes
Reply
1 Solution
dslr595148
Community Leader
Community Leader

@newbieuser wrote:

I am having the same issue. I can do port forwarding for RDP. It use to work before I upgraded to the G3100.

I have tried everything.

I have tested the port and its open but still cant RDP. I can do it inside the network but outside I cant. I use IP and my DDNS and still no luck.

I done it this way but still does not work..Keep in mind I used port 3389 not the one in the example. I got the photo from the internet. But its the same configuration but using port 3389 for both UDP and TCP.


See if the port is open from the outside.

#1 This could mean using a port checker.

An example of a web based port checker, is

https://www.yougetsignal.com/tools/open-ports/

If you use a web based port checker, be sure that:

the server is in the listening state and you are forwarding the ports that you want to check.

If you use an inbound client side port checker like http://www.pcwintech.com/simple-port-tester or from https://portforward.com/help/portcheck.htm then be sure that:

you are forwarding the ports that you want to check and the server that you are trying to forward is NOT in the listening state.

Stated reason that the server that you make sure the server trying to forward is NOT in the listening state when using an inbound client side port checker, when using this kind of port checker - it will try to listen on that port and you can not have two servers listening on the same port at the same time.

#2 Or you can have someone try to connect from the outside. When they do this, it does not have to be for RDP if desired - it just has to be server of sorts.

#3 Once you know that the port is open from the outside (not talking about from behind the router), it will be explained what is going on.

View solution in original post

21 Replies
LawrenceC
Moderator Emeritus

As this thread is now over two years old, it will be locked in order to keep discussions current. If you have the same or a similar question/issue we invite you to start a new thread on the topic.

0 Likes
Reply
GlockMan34
Enthusiast - Level 1

How to add Port Forwarding Group of ports/protocols to your firewall:

First create a Port Forward Rule, go to Advanced/Security & Firewall/Port Forwarding Rule. Create a rule and add all the protocols/ports needed (e.g. L2TP) and save it. You'd think you could go to "Port Forwarding" and add it now but it doesn't show in the drop down list. Navigate to Advanced/Network Settings/Static NAT, create a rule adding your device, your public IP, select the check box "Enable Port Forwarding" then select the "Port Forwarding Rule" you created. It'll be on the drop down list. Apply your changes, navigate to Port Forwarding and you'll see a new Group rule was added. This worked perfectly for me to enable L2TP and all the protocols & ports it requires. I've attached some screen pics to help. Hope this helps, it was a pain to figure out. 

image

image

image

image

PedalLove
Enthusiast - Level 1

I have a G3100 ( HW: 1103, FW: 1.3.6.27) and have not been able to get port forwarding to work. Can anyone confirm that it does in fact work on this model and firmware? I've heard that there are some versions where it doesn't work at all. I'd like to know if my problems are caused by my settings or if the router has a problem.

Thanks.

0 Likes
Reply
PedalLove
Enthusiast - Level 1

I solved my own issue and got port forwarding to work. I had to delete the entry in Port Forwarding Rules that I had set up for the port I needed and instead, specifically identify the ports in the Firewall - Port Forwarding section. It seems like creating a port forwarding rule for my application and applying it in the firewall doesn't work. In the Firewall section, I simply had to use the "Custom Ports" option instead of the application rule that I had created previously. Now it works!

SalG53
Enthusiast - Level 1

SOLVED!!!

Left Menu: Firewall

Top Menu: Port Forwarding

Select Advanced in center of options

Select IP From Left Dropdown

Select: Custom Ports from Right Dropdown

Protocol = TCP

Source Ports = ANY

Destination Ports = Select Specify & (enter the port)

Select Add

Complete  🙂

Check that the port is open on : https://www.yougetsignal.com/tools/open-ports/

idiot_wind
Enthusiast - Level 3

Great!!  Nice work!! Thanks for sharing, when I have a couple of minutes and the ability to test I will try your solution.   Thanks again for sharing!!!

0 Likes
Reply
dude31
Newbie
 

can't access my camera system via internet after getting new router  it only works on WiFi but not outside  tried all that port forwarding stuff and still can't fix it    ( I'm a computer illiterate) Help

thx

 
 
  •  
0 Likes
Reply
Capricorn1
Community Leader
Community Leader

I don't have this router myself, but it's got a pretty big G3100 User Manual as a PDF you can download. Port forwarding starts on page 93. It looks reasonably similar to how the G1100 worked.

newbieuser1
Newbie

I am having the same issue. I can do port forwarding for RDP. It use to work before I upgraded to the G3100.

I have tried everything.

I have tested the port and its open but still cant RDP. I can do it inside the network but outside I cant. I use IP and my DDNS and still no luck.

I done it this way but still does not work..Keep in mind I used port 3389 not the one in the example. I got the photo from the internet. But its the same configuration but using port 3389 for both UDP and TCP.

I even did it for 3389 --> 3389 instead of TCP any and UDP any

image

0 Likes
Reply
dslr595148
Community Leader
Community Leader

@newbieuser wrote:

I am having the same issue. I can do port forwarding for RDP. It use to work before I upgraded to the G3100.

I have tried everything.

I have tested the port and its open but still cant RDP. I can do it inside the network but outside I cant. I use IP and my DDNS and still no luck.

I done it this way but still does not work..Keep in mind I used port 3389 not the one in the example. I got the photo from the internet. But its the same configuration but using port 3389 for both UDP and TCP.


See if the port is open from the outside.

#1 This could mean using a port checker.

An example of a web based port checker, is

https://www.yougetsignal.com/tools/open-ports/

If you use a web based port checker, be sure that:

the server is in the listening state and you are forwarding the ports that you want to check.

If you use an inbound client side port checker like http://www.pcwintech.com/simple-port-tester or from https://portforward.com/help/portcheck.htm then be sure that:

you are forwarding the ports that you want to check and the server that you are trying to forward is NOT in the listening state.

Stated reason that the server that you make sure the server trying to forward is NOT in the listening state when using an inbound client side port checker, when using this kind of port checker - it will try to listen on that port and you can not have two servers listening on the same port at the same time.

#2 Or you can have someone try to connect from the outside. When they do this, it does not have to be for RDP if desired - it just has to be server of sorts.

#3 Once you know that the port is open from the outside (not talking about from behind the router), it will be explained what is going on.

TJ771
Newbie

1) Goto Firewall -> Port Forwarding

2) Enter IP address from the Select IP from Menu

3) Under Application to Forward, enter the custom IP address

4) Click the "Add>" on the next line.  Do *not* click the Apply at the bottom of the page.

The "Apply" button is for updating any change in Applied Rules.

0 Likes
Reply
idiot_wind
Enthusiast - Level 3

Hello,

I believe that I am having the same issue.

- I can use RDP on the local 192 LAN with no issues.

- I can get to the DynDNS hostname externally to login into the router.

- When using port checker on the PC that I am trying to connect to I see

0 - Port 3389 is closed on IP ADDRESS OF THE ROUTER  when port forwarding is disabled

0- Port 3389 is open  on IP ADDRESS OF THE ROUTER  when port forwarding is enabled.

Any additional direction would be greatly appreciated.

Best regards,

frank

0 Likes
Reply
cram1
Newbie

So your port forwarding worked with DynDNS enabled?

0 Likes
Reply
dslr595148
Community Leader
Community Leader

@idiot_wind wrote:

Hello,

I believe that I am having the same issue.

- I can use RDP on the local 192 LAN with no issues.

- I can get to the DynDNS hostname externally to login into the router.

- When using port checker on the PC that I am trying to connect to I see

0 - Port 3389 is closed on IP ADDRESS OF THE ROUTER  when port forwarding is disabled

0- Port 3389 is open  on IP ADDRESS OF THE ROUTER  when port forwarding is enabled.

Any additional direction would be greatly appreciated.

Best regards,

frank


Since you got that far:

a) 🙂

b) See the thread Port forwarding only works seen from outside my local network? 

idiot_wind
Enthusiast - Level 3

Thanks for the response, unfortunately I am still having an issue connecting from outside my LAN.  I am using a static IP on my Windows 10 box and manually added that IP address to the DNS server tab/page under the Advanced page, still no luck.

Another interesting thing is that when connecting to the G3100's login page from the external IP address I can login in but the username and password but a configuration page is never displayed, using Chrome I get nothing, a blank page, using MS Edge I get:

403 Forbidden

Your client does not have permission to get this page.from this server.

Also during the troubleshooting process I set the IPv4 firewall setting to Minimum Security, but no difference. also tried the IPv6 Pinholes but when trying to add  a specific IP (192.168.x.xxx) I received Error: The local host specified is invalid, I am guessing that this is because the PC is not running IPv6.

All works well when on local LAN between 2 Windows boxes with RDP but not when trying to access from externally.  Are you aware of some logs that I can look at on the router that might give some hint as to what is happening, the logs that I saw did not tell me much.

Thanks in advance.

frank

0 Likes
Reply
mhennessie
Newbie

I just upgraded from the quantum router to the G3100 and I am also experiencing issues when trying to connect to a device while on my local network and using a hostname from no-ip.com. When I am on an outside network I do not have any issues connecting and locally I can connect to the desired devices using the local IP but the hostname does not resolve. The correct ports are open and adding the hostname the DNS server setting on the G3100 has no effect. Any help would be great as I would like to get my network set back up.

I had no issue prior to the upgrade.

0 Likes
Reply
Famgh902
Newbie

I'm having exactly the same issues. I can see my IP cameras from the outside or turning my wifi off on my phone an using cellular data. But if I check them using my wifi since the link I have configured in the IP viewer cam is using the DDNS host name It won't connect. This worked fine with my previous modem (optimum).

Did you fix your issue?

0 Likes
Reply
idiot_wind
Enthusiast - Level 3

Greetings,

I have made the modifications but as of yet have not have the ability to fully test.

How did you make out?

0 Likes
Reply
Rcgus
Enthusiast - Level 3

Same here.  Port forwarding isn't working.  No issues years before on several generations of FIOS routers.

0 Likes
Reply
Rcgus
Enthusiast - Level 3

Update - You cant check your port from within the same network of the computer you are trying to connect to.  I tuned off wifi and connected no problem via cellular.  This was suggested in this thread at one point.  Thanks 

0 Likes
Reply