Routing/DNS problem, Steam downloads failing unless I VPN.


Any suggestions on my problem below would be most welcome.


My Steam client times out almost immediatly when it tries to download games or updates to games.


I first noticed my problem when I tried to download an update to one of the games I own through Steam.  The client was throwing an error about the download being corrupt but that turned out to be a read herring.  After a ton of testing and research I found part of the issue to be DNS resolution.  I was able to verify this because after I connect to a VPN (it uses Comcast on their other side) the problem goes away.  I believe this works because it forces me to use a different DNS source and the connection takes a different route.

The DNS issue:

The domain Steam uses is which should resolve to 23.78.179.XXX, but instead was resolving to which is a business called "Cadillac Shores" in Chicago.  I fixed this by changing the DNS server on my router from what FIOS was pushing to Google's DNS of  

Here is a screenshot of a tracert without VPN and then with VPN (my IP is obfusicated).


As you can see the DNS resolution was the first problem.  Here is my trace after the DNS change:


It looks like I may be getting the right address now but as you can see my path is different and Steam still doesn't work. Does anyone have any ideas?  It seems to me this is a Verizon problem but a network engineer I am not (I support applications) and I don't know what else to try.

PS:  I also tried changing my download server location in Steam but none of those other selections resolved the issue.

Tags (4)
Re: Routing/DNS problem, Steam downloads failing unless I VPN.
Community Leader
Community Leader

What setting is the Firewall set to on your router?

Re: Routing/DNS problem, Steam downloads failing unless I VPN.
Enthusiast - Level 2

Something looks odd about the DNS reolution for steampower.  You seem to be getting two different IP addresses in the 23.. series.  I get still a different IP address, specifically I get  This differs from the two IP addresses you got that both begin with 23.  I also tried some further IP lookups for a few minutes later, and get some different IP addresses,, and then

A tracert to any of these IP addresses shows the endpoint is  So it looks like steampower is doing dynamic IP resolution with the application hosted at an akamai server.  The steampower ap should be able to work with the IP address selected for your session.  You may be confusing the ap when you try to connect via a VPN.  Why not ask steampower suppoort how to use a VPN with the steampower service.  Or try accessing steampower without a VPN.  Unless you are in an airport or hotel you shouldn't need a VPN.