Setting up DMZ on Fios Router
pls60
Enthusiast - Level 2

I'm trying to set up my own router (Dlink) to go with my Fios router (G1100).  My reading/research tells me that the best way to do this is to set up a DMZ to my Dlink router.  My Fios router is connect to the WAN port on the Dlink.  My problem:  the Fios DMZ setup only allows me to change the last octet of the IP address, yet I need to change it to match the IP address of my Dlink router (192.168.0.1) which means I'll at least need to be able to change the 3rd octet (everything is greyed out except the 4th octet).  What am I missing?  Thanks in advance.

0 Likes
1 Solution
JustinG1
Community Leader
Community Leader

Actually the steps are the same for both the Actiontec and the G1100. 

Regarding breaking your internet, no matter how bad things may get, its a matter of plugging in everything the way it was and factory resetting the G1100 to get back to the way you were. (It might be helpful to take photos of your current setup just in case). 

Quick question before proceeding, did you want to use the G1100's wifi or your D-Links wifi? This method would rely on the D-Link's wifi (there is another way around this, but it gets even more complicated). 

Here is a rundown of what you will want to do:

Firstly make sure your G1100 is set to factory settings, and dosen't have any custom settings on it. Now, connect your computer to the G1100 (Either via wifi or ethernet). Go to the page http://192.168.1.1/ and login. The username and password are on the side of the device. 

Follow these directions to release the DHCP lease, which allows your D-Link router to connect to the internet. 

1Click on the My Network icon at the top.
2Click Network Connections from the menu on the left.
3Click Broadband Connection
4Click Settings
5Scroll down and click Release under DHCP Lease
6Click Apply
7Disconnect the router immediately to prevent it from re-requesting a DHCP lease.

Once you have done those steps, remove the ethernet cable from the white WAN port of the G1100 router, and plug it into the WAN port of your D-Linnk router, like so:

image

Check to make sure your D-Link router has internet access. 

From this point on, I will be assuming that your D-Link's LAN range is 192.168.0.1/24 and not 192.168.1.1/24. If you do switch it one day to a 192.168.1.1/24 network, this will interfere with the set top boxes. 

Now to give internet to the set top boxes (required for on demand and guide info), plug an ethernet cable from the LAN port of your D-Link router to the WAN port of the G1100, like this:

image
Now boot up the G1100, and make sure your STBs don't complain about connectivity. 

This step is optional: disable WiFi on the G1100 by connecting a computer back to its network, and logging into http://192.168.1.1/.

Click Wireless Settings, click Basic Security Settings, then turn 2.4 GHz Wireless to Off, and do the same for 5 GHz wireless. 

While you may be wondering why we want to do this. We don't want to use the G1100's WiFi in this situation because everyone connected behind it will be behind a double NAT (not good for networking). The G1100 in this configuration now merely acts as a bridge for the Set top boxes to give them internet access. 

View solution in original post

14 Replies
pls60
Enthusiast - Level 2

Well, after following all listed instructions (Thanks JustinG!), I've been successfully using my own router and using the Fios router for TV purposes.  I've had no issues.

I've now added a Quantum DVR, and while I'm up and working now, it wasn't easy.  Basically, the Media Server (DVR) couldn't activate with my setup (primary Dlink router, secondary Fios router).  I had to connect the Fios router back up as primary.  (Apparently, the activation process required the Fios router be seen?).  At any rate, the activation worked and I again followed the listed instructions and my Dlink is primary again and the DVR works.

New question:  I'm adding a client box to the system (to utilize the whole house DVR capability).  I'm assuming I'll have similar problems with activation, but I'm concerned with the the Media Server being able to talk to the client box when I ultimately connect my Dlink router as primary.  Any thoughts? 

JustinG1
Community Leader
Community Leader

Two questions, do you have TV service, and if so, do you have remote DVR options?

Also, how does the internet come into your Verizon FiOS router, is it by a coax cable or ethernet? 

image

If your Verizon router has an ethernet cable going into the white WAN port, save yourself a bunch of headache and make your D-Link router the primary router. 

The DMZ will still cause Double NAT headaches. For your setup I would strongly advise you make the d-link your primary internet gateway. 

If you do have TV service and you are concerned that you will loose video on demand and guide info, fear not, the process is quite simple. The only feature that won't work with this setup is remote DVR. 

If you did want to follow this route, DSL Reports has some great tutorials on replacing the Verizon router. Check out this link: http://www.dslreports.com/faq/verizonfios/3.2_Actiontec___FiOS_Quantum_Gateway

Also feel free to post back here with any questions or concerns. 

pls60
Enthusiast - Level 2

Thanks for the feedback JustinG.

I looked at the link you recommended, but don't see any info on my Fios router (G1100) or on setup.

I do have Fios TV but do not have a DVR.  It's a new house that I haven't moved into yet and I'm still in experimental mode.  I'm looking into TiVo.

What about your instructions in another topic concerning using my own router but keeping the guide.  Would those instructions apply to me? 

I'm a bit afraid of reaching a point of no return with many changes that leave me with no internet at all.

Thanks again.

0 Likes
JustinG1
Community Leader
Community Leader

Actually the steps are the same for both the Actiontec and the G1100. 

Regarding breaking your internet, no matter how bad things may get, its a matter of plugging in everything the way it was and factory resetting the G1100 to get back to the way you were. (It might be helpful to take photos of your current setup just in case). 

Quick question before proceeding, did you want to use the G1100's wifi or your D-Links wifi? This method would rely on the D-Link's wifi (there is another way around this, but it gets even more complicated). 

Here is a rundown of what you will want to do:

Firstly make sure your G1100 is set to factory settings, and dosen't have any custom settings on it. Now, connect your computer to the G1100 (Either via wifi or ethernet). Go to the page http://192.168.1.1/ and login. The username and password are on the side of the device. 

Follow these directions to release the DHCP lease, which allows your D-Link router to connect to the internet. 

1Click on the My Network icon at the top.
2Click Network Connections from the menu on the left.
3Click Broadband Connection
4Click Settings
5Scroll down and click Release under DHCP Lease
6Click Apply
7Disconnect the router immediately to prevent it from re-requesting a DHCP lease.

Once you have done those steps, remove the ethernet cable from the white WAN port of the G1100 router, and plug it into the WAN port of your D-Linnk router, like so:

image

Check to make sure your D-Link router has internet access. 

From this point on, I will be assuming that your D-Link's LAN range is 192.168.0.1/24 and not 192.168.1.1/24. If you do switch it one day to a 192.168.1.1/24 network, this will interfere with the set top boxes. 

Now to give internet to the set top boxes (required for on demand and guide info), plug an ethernet cable from the LAN port of your D-Link router to the WAN port of the G1100, like this:

image
Now boot up the G1100, and make sure your STBs don't complain about connectivity. 

This step is optional: disable WiFi on the G1100 by connecting a computer back to its network, and logging into http://192.168.1.1/.

Click Wireless Settings, click Basic Security Settings, then turn 2.4 GHz Wireless to Off, and do the same for 5 GHz wireless. 

While you may be wondering why we want to do this. We don't want to use the G1100's WiFi in this situation because everyone connected behind it will be behind a double NAT (not good for networking). The G1100 in this configuration now merely acts as a bridge for the Set top boxes to give them internet access. 

Khadijah81
Newbie

Question: does this setup also work for the Netgear Nighthawk router? I currently have my G1100 as primary & my Nighthawk behind it. I would like to use my Netgear as primary, but both the routers default IP addresses are the same (ie: 192.168.1.1). I too have a DVR & another STB. How would I configure the IP’s in this case? Should I just lower the second to last digit on my Netgear (make the 1 a 0, or make the second to last digit a 2 on the G1100?

0 Likes
CRobGauth
Community Leader
Community Leader

SHould be able to do the same config regardless of router model.

pls60
Enthusiast - Level 2

Thanks JustingG.  You're helping my confidence.

Yes, I intend to use the Dlink wireless which is the main reason I've purchased my own Dlink router.  I just don't trust the capability of the Fios G1100.  I plan on having a lot of smart devices in my new home.

So, I think I understand:  Basically I'm going to be hanging the G1100 as a client off of my Dlink (primary).  However I'm confused about the subnet issue:  if the Dlink defaults to the 192.168.0.xxx range but the G1100 defaults to the 192.168.1.xxx range, won't the G1100 pick up (via DHCP) an address in the 192.168.0.1 range resulting in a problem with the G1100 talking to the STB's ?

JustinG1
Community Leader
Community Leader

Correct. The G1100 will become a client of the D-Link network. 

Your also correct that the G1100 will get an IP from the 192.168.0.X network (d-link network). This won't be a problem, because it sees that IP as its WAN address. Here is a better way of describing it:

Your D-Link will give the G1100 an address of 192.168.0.2. The Verizon box uses this as its WAN IP. Whenever the STBs connect to the Verizon box, it will hand out 192.168.1.X IPs to them. This is called a Double NAT. Its not ideal for normal networking situations, but the set top boxes don't care in this situation. The set top boxes will still get internet by going from: STB (192.168.1.99) -> G1100 (192.168.0.99) -> Dlink (192.168.0.1) -> Internet

Basically  back to the roots of your question, this would not interfere with the set top boxes, because the G1100 treats the 192.168.0.X from the D-Link as WAN, and therefore a completely seperate interface from its LAN interface, which is configured for 192.168.1.X. 

I apologize if thats not the most clear explanation in the world, but hopefully I could convey the idea. 

As long as your D-Link dosen't hand out 192.168.1.x (the same range as the G1100), you won't run into any trouble. 

If you don't mind me asking, just out of pure curiousity, what model D-Link router do you have? 

pls60
Enthusiast - Level 2

I bought the Dlink DIR-890L/R.  It seems to be tried and true.  A couple weeks ago I purchased the DIR-895 (maybe overkill) but the 2.4ghz didn't work out of the box.  Further research showed the 895 had lots of problems based on Amazon reviews.

Your explanation is perfect.  Basically, using the Dlink as primary swaps the double NATing to the G1100 but as long as I don't need to talk to my DVR externally (it wouldn't be found), I'm in business.  Besides, I'm considering getting a TiVo setup.  Any thoughts on TiVo?

I'll be attempting all this tomorrow when I'm back at the house.

Great conversation! 

0 Likes
jonjones1
Legend

@pls1960 wrote:

I'm trying to set up my own router (Dlink) to go with my Fios router (G1100).  My reading/research tells me that the best way to do this is to set up a DMZ to my Dlink router.  My Fios router is connect to the WAN port on the Dlink.  My problem:  the Fios DMZ setup only allows me to change the last octet of the IP address, yet I need to change it to match the IP address of my Dlink router (192.168.0.1) which means I'll at least need to be able to change the 3rd octet (everything is greyed out except the 4th octet).  What am I missing?  Thanks in advance.


https://www.dslreports.com/faq/verizonfios?

The above link should help you. You have to place your D-Link in access point mode.

follow the instructions at the link I provided you.

0 Likes
pls60
Enthusiast - Level 2

Thanks again.

I'm setup the way you said:  Quantum 192.168.1.1 (primary)   Dlink 192.168.0.1 (secondary-WAN).  I'm just concerned that without the DMZ I will have the double NAT problem that will cause problems with accessing home-automation devices.

0 Likes
jonjones1
Legend

@pls1960 wrote:

Thanks again.

I'm setup the way you said:  Quantum 192.168.1.1 (primary)   Dlink 192.168.0.1 (secondary-WAN).  I'm just concerned that without the DMZ I will have the double NAT problem that will cause problems with accessing home-automation devices.


The only way to see if your home automation still functions is through a test after you are up and running. Hopefully this will all turn out ok.

0 Likes
pls60
Enthusiast - Level 2

Thank you for the feedback.  I reviewed the link and your comments.  Unfortunately, It doesn't help resolve my problem.  I'm not trying to extend the wi-if network with an additional router.  Rather I'm trying to keep the Fios router in its mostly default state (I have Fios TV) and connect a 2nd router that will provide all internet access -- wired and wi-if (disabled on Fios router).  The DMZ route is recommended in many links.

0 Likes
jonjones1
Legend

@pls1960 wrote:

Thank you for the feedback.  I reviewed the link and your comments.  Unfortunately, It doesn't help resolve my problem.  I'm not trying to extend the wi-if network with an additional router.  Rather I'm trying to keep the Fios router in its mostly default state (I have Fios TV) and connect a 2nd router that will provide all internet access -- wired and wi-if (disabled on Fios router).  The DMZ route is recommended in many links.


Let's look at it this way:

ethernet from ont to wan port on Quantum G1100 you then have Internet address (dns) to the G1100.

Now you take the D-Link and in its settings make it an Access Point (AP Mode) it then extends the capabilities of the Quantum Gateway G1100 as you then turn off the wifi both bands, and the guest network in the routers settings.

you then connect an Ethernet to the wan port on the D-Link.

after you turn off wifi from the Quantum your D-Link is the router that assigns the ip addresses for your connections and with wifi enabled on the D-Link you are using wifi from that router and not the Quantum 

0 Likes