Slow Google response / router problem
njx
Enthusiast - Level 2

I was having a lot of problems accessing Google Web sites.  Google search was slow, Gmail was slow and sometimes unresponsive.  Speedtest download was horribly slow (I have 1 gig service.)   I did a lot of research on the Web, and discovered that there is an issue with the Verizon router.  The workaround is to either disable ipv6 on the Ethernet adapter properties, or disable TCP Checksum Offload.  This fixed the problem immediately.

I spent a lot of time with Verizon customer support, and of course they knew nothing about this.  We went through the whole process of resetting the router, having them check the response, etc.   Ultimately, they advised me to call Dell because my router was working fine and therefore it's a computer problem!  NO, IT'S YOUR ROUTER.  I had to do my own homework to discover the problem.   Fooling around with the network adapter properties is not something we should have to do.

Labels (1)
0 Likes
3 Replies
Cang_Household
Community Leader
Community Leader

If your computer uses Intel NIC, then 90% of the time the problem lies on your computer.

0 Likes
smith6612
Community Leader
Community Leader

The problem is actually an issue with the Nokia ONTs Verizon is using. They are in need of a software update to fix the IPv6 packet mangling bug.

0 Likes
smith6612
Community Leader
Community Leader

Just to add to the fix. Don't forget to disable UDP Checksum Offloading in your Ethernet NIC as well. Google uses a protocol called QUIC, which runs over UDP. UDP is also affected by the bug which causes TCP Offloading to break.

DNS also uses UDP 🙂

0 Likes