TP LInk RE650 Dropping 5g signal
vpac1
Enthusiast - Level 2

When recently setting up my RE650 with my Verizon FiOS Quantum Gateway router, the initial set-up and wireless network connections went seamlessly. After about 3 hrs, the RE650 quit recognizing the 5G network and the 5G LED on the RE650 went dark despite the fact that the 2.4G network continued to work fine--other devices (ie, cell phones, tablets, laptops, etc. could still see the host 5G network from the dual band Verizon FiOS Quantum Gateway router). I immediately updated firmware to version 1.0.6, but that didn't work. Reinstalled version 1.0.2. No luck. Went to firmware version 1.0.4, still no luck. Went back to 1.0.2, and after numerous reboots (router and range extender) and reset attempts of the range extender still no luck, Any suggestions.

0 Likes
Reply
1 Solution
jonjones1
Legend

From another forum.

Recently, Verizon pushed new firmware to their devices which enabled a new Self-Organizing Network (SON) mode. This new mode simplifies the home network to a single WiFi name and improves performance by automatically connecting devices to the nearest access point using the optimal network band (2.4 or 5GHz)”

if it is set to on turn it off. The SON is supposed to get the best band for your connections. However certain devices that need 2.4 Ghz won’t connect and vis a vie on the 5 Ghz band. 

this might be your issue.

View solution in original post

3 Replies
smith6612
Community Leader
Community Leader

I second jonjones's advice. SON will cause problems with third party range extenders and should be disabled.

If you can get Ethernet to the range extender, consider putting it into Access Point Mode instead. This way you get better performance wirelessly, and are not handicapped by having to repeat a signal from the FiOS router.

jonjones1
Legend

From another forum.

Recently, Verizon pushed new firmware to their devices which enabled a new Self-Organizing Network (SON) mode. This new mode simplifies the home network to a single WiFi name and improves performance by automatically connecting devices to the nearest access point using the optimal network band (2.4 or 5GHz)”

if it is set to on turn it off. The SON is supposed to get the best band for your connections. However certain devices that need 2.4 Ghz won’t connect and vis a vie on the 5 Ghz band. 

this might be your issue.

vpac1
Enthusiast - Level 2

Hi There -

I have already done that before posting on this forum. The funny thing is that my other devices ie smart phones , tablets, laptops see the 5g signal, its just the TP Link RE650 not seeing it.