Use old Verizon Westell router with FIOS service?


I recently moved and had FIOS service set up. I didn't want to buy a new router, since I had an old Verizon-branded Westell A90 router that had been used for less than a year and was in great condition. However, it is 8 years old. (made 2011). The installation tech told us that we could use any router we wanted and ran an ethernet cable into the house for us to plug into the router. We did so, and it worked well immediately - network started broadcasting with strong signal immediately, we were able to connect multiple devices, etc.

After a few days, however, the Internet connection suddenly went down. The router seems to be broadcasting fine, because devices can connect to the network, but it says "connected - no Internet", and there is indeed no Internet available on the network. When I plug the FIOS cable straight into my laptop the Internet works fine. Even stranger, one device (Kyocera Internet-enabled flip phone) seems to be able to connect to the Internet through the router, even though nothing else can. 

I have tried unplugging and disconnecting everything - doesn't help. Is there any way I can get this working again? I know the router is very old, but our needs are simple (no gaming or streaming) and I'd rather not spent $100+ on a new router.


1 Reply
Community Leader
Community Leader

Did you try a hard reset in the back with a pencil? Hold in for about 10 seconds and when it comes back up try to get back on the internet.