iComfort Thermostat
Woodstock1
Newbie

 I recently upgraded to a FiOS Quantum Gateway supporting a desktop PC via a LAN Ethernet connection and mobile devices (laptop/tablet/Smartphone) via wireless connections.   Post upgrade, all are working as desired.  However, my primary purpose for the upgrade was to obtain greater wireless range to reach my Lennox iComfort thermostat in a not too distant hallway.  It didn’t happen!  I’m thinking there are too many obstacles between the router and the iComfort. The iComfort does interface with the internet if the router is near (30 feet or less).  Unfortunately, it is not practical, nor desired, to relocate the router.  Further, a wireless extender device is not desired; tried one with limited/unreliable results.  I’m in pursuit of a solution for getting the iComfort wirelessly connected to the internet without a wireless extender.  Got any options?  (What about a second access point? How would it work?  What would I order?  What would it cost (onetime / recurring?) 

0 Likes
1 Reply
TomH121
Community Leader
Community Leader

GO HERE  HOPE IT HELPS YOU

http://www.amazon.com/gp/product/B00H67K208?tag=ttrprogramthermostat-20&ascsubtag=[site|ttr[cat|965[...

Lennox iComfort Thermostat Wi-Fi Disconnecting Problem Fixed...(at least for the unit I have...)

By SunnyM on July 24, 2014

Recently I got a whole Lennox system and this thermostat came with it. Initially, I had this "Wi-Fi disconnecting" problem and it is very frustrating. After a lot of trials & errors, I figured a sequence of steps that gets your Wi-Fi back online and mine has not disconnected since then. This will be a trial & error try, depending on your particular T'stat, but there is no harm in trying...:

Touch Wi-Fi button. This will take you to a second screen that will show you various Wi-Fi sources available to connect. Try to connect to one of that shows the highest signal bars. But while it is trying to connect, press some f the other buttons (I cannot see those now because mine is connected...)...eventually, you will only see 2 o3 buttons: Status, Wi-Fi Enabled, etc.. Press the Wi-Fi Enabled button and disable the Wi-Fi. Go to Home screen and press and hold the "Lennox" button (bottom right) to cycle the T'stat. Once it comes back up, go to Wi-Fi screen and "Enable" Wi-Fi. Now you will see the sources again. Select the one that has the highest signal and enter you necessary password and it should connect with a minute or so. In case you have "WPS" enabled, you do not have to enter any password...simply start your routers "WPS" procedure and then use the T'stat's Wi-Fi to connect and it should do the job... You may have to repeat these steps a few times, but I hope this helps

 PLEASE NOTE THAT ALL OF ABOVE INFO IS FROM THAT SITE I DO NOT OWN THE TST.

0 Likes