very slow internet on new 1 GB system
stellab1
Enthusiast - Level 2

We just upgraded to 1 GB router and system and are experiencing very slow internet.  When running Verizon speed test it shows fast download and upload speeds but when using third party speed test (Google) it shows very slow upload speed (less than 1 mbps).  Our Youtube music videos are always buffering and certain websites like Amazon are hanging.

One other user suggested disabling IPv4 in the ethernet controller settings.  How do I do this?  I am not the most computer savvy.

 

Labels (1)
0 Likes
Reply
1 Solution
smith6612
Community Leader
Community Leader

If this is only happening on Ethernet devices, go into the the Device Manager on your PCs and disable IPv6 Checksum Offload for TCP and UDP. The steps are:

  1. Right click the Start Menu button
  2. Open the Device Manager
  3. Open Network Adapters. Find your Network Adapter (Intel I211-V for example) and double click on it
  4. Click the Properties Tab.
  5. Find "IPv6 Checksum Offload (TCP)" and "IPv6 Checksum Offload (UDP)." For each option, set it to Disabled.
  6. Click OK
  7. Try your speed tests and services again to see if they work any better.

Other Ethernet devices may also be affected, so look for similar settings if you use Realtek, Qualcomm, Aquantia, etc Ethernet.

If you're seeing problems with wireless devices, especially Smart TVs and Streaming Devices, what you want to disable is IPv6, not IPv4.

To do this, log into your Verizon Router at https://myfiosgateway.com/ using the Credentials found on the side of the router. Once in, go to Advanced --> IPv6. Set IPv6 to Disabled and click Apply.

View solution in original post

1 Reply
smith6612
Community Leader
Community Leader

If this is only happening on Ethernet devices, go into the the Device Manager on your PCs and disable IPv6 Checksum Offload for TCP and UDP. The steps are:

  1. Right click the Start Menu button
  2. Open the Device Manager
  3. Open Network Adapters. Find your Network Adapter (Intel I211-V for example) and double click on it
  4. Click the Properties Tab.
  5. Find "IPv6 Checksum Offload (TCP)" and "IPv6 Checksum Offload (UDP)." For each option, set it to Disabled.
  6. Click OK
  7. Try your speed tests and services again to see if they work any better.

Other Ethernet devices may also be affected, so look for similar settings if you use Realtek, Qualcomm, Aquantia, etc Ethernet.

If you're seeing problems with wireless devices, especially Smart TVs and Streaming Devices, what you want to disable is IPv6, not IPv4.

To do this, log into your Verizon Router at https://myfiosgateway.com/ using the Credentials found on the side of the router. Once in, go to Advanced --> IPv6. Set IPv6 to Disabled and click Apply.