Arris PC1100
hishandsomeness

I have 3 STBs the main box works well, but the 2 saecondary boxes have defective displays, 1 box is completely blank. The other has sporadic LEDs lit at various times. I can no longer see the channel and I can no longer see the time. This condition was gradual, about six months after I got fios the LEDs just started to disappear. I've contacted Verizon numerous times but their people don't seem to understand my problem and keep referring me to their on line troubleshooter that doesn't address this problem. I've even asked for replacement boxes. Can any one help me get my displays to work again?

0 Likes
Reply
1 Reply
LawrenceC
Moderator Emeritus

Hi hishandsomeness,

Your issue has been escalated to a Verizon agent. Before the agent can begin assisting you, they will need to collect further information from you. Please go to your profile page for the forum and scroll down the page to an area titled "My Support Cases". You can reach your profile page by clicking on your name located above your post, or at the top right of this page.

Under "My Support Cases" you will find a link to the private board where you and the agent may exchange information. The title of your post is the link. This should be checked on a frequent basis, as the agent may be waiting for information from you before they can proceed with any actions. To ensure you know when they have responded to you, you may subscribe to the case. At the top right of your support case there is a gear icon which provides a drop down menu with support case options. Click that and choose "subscribe". Please keep all correspondence regarding your issue in the private support portal.

0 Likes
Reply