HELP! Projector Displays Static When Attached to Fios One Mini Box
OhMyAchinBack
Newbie

When I connect my Fios One Mini Box to my Epson 4050 projector using a HDMI, all I get is static. Please help me keep my sanity during these crazy times.

Thanks & stay safe 🙂

0 Likes
Reply
1 Solution
clem21
MVP MVP
MVP

@OhMyAchinBack wrote:

When I connect my Fios One Mini Box to my Epson 4050 projector using a HDMI, all I get is static. Please help me keep my sanity during these crazy times.

Thanks & stay safe 🙂


First, did you try the mini with another TV to make sure it is outputting a signal?

If I remember correctly, that projector should work if you send it 1080i. So try setting the mini to 1080i, and reconnect to the projector. Also check the length and quality of the cable. Over 25' is asking a LOT from a passive HDMI cable. If you are trying to get 4K out of the box you need to use certified high-speed hdmi cable, standard cables won't work. And of course it could just be a bad cable.

View solution in original post

1 Reply
clem21
MVP MVP
MVP

@OhMyAchinBack wrote:

When I connect my Fios One Mini Box to my Epson 4050 projector using a HDMI, all I get is static. Please help me keep my sanity during these crazy times.

Thanks & stay safe 🙂


First, did you try the mini with another TV to make sure it is outputting a signal?

If I remember correctly, that projector should work if you send it 1080i. So try setting the mini to 1080i, and reconnect to the projector. Also check the length and quality of the cable. Over 25' is asking a LOT from a passive HDMI cable. If you are trying to get 4K out of the box you need to use certified high-speed hdmi cable, standard cables won't work. And of course it could just be a bad cable.