Lip Sync with Fios STB (VMS4100)
Mbpe300
Enthusiast - Level 2

Hey Verizon,

I have a new Fios TV installation and there is an audio delay issue from the STB when Dolby Digital 5.1 (surround) Audio Format is selected.

Switching to LPCM (stereo) Audio Format fixing the issue but I did not sign for the TV service to hear the channels in stereo on my home theater setup and definitely not to watch them with annoying lip sync issues.

The delay happens in both HDMI and OPTICAL outputs from the STB.

Just to clarify, the audio stream is being sent with a delay and lagging the video stream, which means that the "Audio Delay" function that is common in the various devices can't help.

Please provide a solution and by solution I mean something serious and not the: "replug the power", "reconnect the cables", "try different cables", etc. 

0 Likes
Reply
55 Replies
bstpeg
Newbie

The way it's currently set up, I can use my TV remote to turn the TV on and off, and the sound bar powers on/off based on what the TV does. That doesn't happen anymore when I turn the TV on and off using passthrough. I'd like to be able to use my TV remote, since I use it to navigate my streaming apps and don't want to have to switch between remotes constantly. 

Also, calling this a "fix" is a bit generous. It's not a fix, it's a workaround. There's nothing wrong with my current setup. I shouldn't have to use a different configuration that relies more heavily on CEC working between devices from multiple manufacturers simply because there's a bug in the FiOS TV One boxes. 

0 Likes
Reply
clem21
MVP MVP
MVP

Did you try this procedure to reset HDMI control for your soundbar? There is troubleshooting advice at the bottom:

Follow the procedure below to enable or disable the unit’s HDMI control function. This function is enabled by default. 1 Turn off the unit. 2 Hold down the HDMI key on the unit’s remote control for more than 3 seconds. The HDMI control function is enabled or disabled, and the unit turns on. The indicator shows HDMI control function status for several seconds immediately after the unit is turned on. NOTE Glows (enabled; default) Off (disabled) • Enable the HDMI control function when connecting a TV that supports Audio Return Channel (ARC) (p. 23), or when using HDMI signal pass-through (p. 23). If the unit cannot be operated with the TV’s remote control Confirm the settings are properly configured as described below.-The HDMI control function of this unit is enabled.-The HDMI control function is enabled on the TV. Examples of TV settings • From the setup menu on your TV, select “Link setting” ➔ “HDMI control setting”, then set a setting such as “HDMI control function” to “ON”. • Set audio output to any option other than TV. If the unit cannot be operated with the TV’s remote control even after the settings described above have been applied correctly:-Turn off this unit and the TV, and then turn them back on again.-Disconnect the power cables of the center unit, subwoofer, and external devices connected to the center unit via HDMI cable. Plug them in again after about 30 seconds.

Just a shot in the dark, but might work for you.

bstpeg
Newbie

I tried it again, resetting the settings like you suggested. Seems like ARC and CEC control just don't play well between TV and soundbar when using the bar to pass through the FiOS box. I'm able to change the channel via the TV but turning on and switching to the right input is just finicky. Having everything go to the TV and only audio out to the bar works the best, though of course with the audio lag issue.

0 Likes
Reply
clem21
MVP MVP
MVP

The whole CEC thing is really frustrating. You'd think by now everyone would have it working correctly,  but some manufacturers just dont really care. Have you tried the optical out from your TV to the soundbar?

bstpeg
Newbie

mbpe300 already said that the same issue happens with optical, so I don't really think I'm going to bother trying. 

0 Likes
Reply
clem21
MVP MVP
MVP

@bstpeg wrote:

mbpe300 already said that the same issue happens with optical, so I don't really think I'm going to bother trying. 


He tried optical from Fios box to TV. Try optical from TV to soundbar. Also I read in posts on Samsung forums that there is a built in 30ms delay baked into the Samsung TVs. The only way to change it is through the service menu. Don't know if it will help, but there are several posts on Samsungs forums about it and how to change it.

bstpeg
Newbie

I spent quite a bit of time reading this thread. It seems to describe the issues I'm seeing including the lip sync, changing to PCM working, and using passthrough working. It also describes the issue with the sound bar not turning on automatically when using passthrough.

The solution for changing the HDMI delay level didn't really make much of a difference for me.


Also, multiple people on that thread indicated that using optical to connect TV to the sound bar didn't make any difference.

0 Likes
Reply
clem21
MVP MVP
MVP

@bstpeg wrote:

I spent quite a bit of time reading this thread. It seems to describe the issues I'm seeing including the lip sync, changing to PCM working, and using passthrough working. It also describes the issue with the sound bar not turning on automatically when using passthrough.

The solution for changing the HDMI delay level didn't really make much of a difference for me.


Also, multiple people on that thread indicated that using optical to connect TV to the sound bar didn't make any difference.


Good to see someone's actually read about the problem with the Samsung TVs recent firmware updates. I'm just trying to give every possible option for people to try in case any of them work. Also good to note that LPCM isn't necessarily stereo only but can be multichannel. Its system dependent,  not sure if the 4100 sends out 2.0 or 5.1 via LPCM. Trying optical can sometimes reduce audio delays that occur with ARC implementation, but sometimes it creates it's own delay. Its unfortunately a problem with the manufacturers not closely following the established standards for AV transmission and we are really lucky when it all works.

Mbpe300
Enthusiast - Level 2

Confidentiality issues?

0 Likes
Reply
clem21
MVP MVP
MVP

They can't release info on fixes until it hits the Public.

Mbpe300
Enthusiast - Level 2

How do you "go" from soundbar to TV?? 

Verizon should fix the issue with the "passthrough".

0 Likes
Reply
clem21
MVP MVP
MVP

Are you going Fios box to TV, then TV ARC to sounndbar or receiver? Did you try Fios box to soundbar or receiver then to TV? Do you get the delay going Fios directly to tv?

Mbpe300
Enthusiast - Level 2

I do get the delay when going directly from Fios to TV or Soundbar via hdmi or optical. Once switched to Stereo the delay is gone.

Also, there are other devices connected to the same TV + Soundbar and there is no audio delay issue with them so it's pretty much clear that the delay happens during DD processing in the STB or even higher upstream. 

Makes me wonder what audio format is reaching the STB from the ONT 🤔

0 Likes
Reply
clem21
MVP MVP
MVP

Supposedly with the latest firmware update there should be a passthrough option in the audio menu. That may do the trick. Problem is the new Fios One boxes convert every signal to DD5.1 regardless of source unless you choose PCM in the service menu. That was why I tried very hard to get the passthrough back in the menu. I have to agree that is the source of the delay in your case, especially if it happens direct to the tv.

Mbpe300
Enthusiast - Level 2

What firmware version has the "passthrough" option?

0 Likes
Reply
clem21
MVP MVP
MVP

Version 6.8 was supposed to have the passthrough restored as an option.

Mbpe300
Enthusiast - Level 2

How the passthrough can be enabled in that version then?

0 Likes
Reply
clem21
MVP MVP
MVP

Not sure if it's in the audio menu, or service menu. Haven't gotten the update myself so I'm not sure where you can access it.

Mbpe300
Enthusiast - Level 2

How the update is done? Automatically or can be initiated manually?

0 Likes
Reply
clem21
MVP MVP
MVP

The updates are initiated on Verizons end. They do them zone by zone until everyone is updated. You can check which version you have in the info in the menu.

Mbpe300
Enthusiast - Level 2

I have the:

Release: APR-6.8

No "passthrough" in the Settings -> Audio...

0 Likes
Reply