TV Guide / VOD Freezing and Unavailable

Hi all, been experiencing some odd TV / STB issues since yesterday morning, and the Verizon support line is adivsing over an hour wait time, so figured I'd give this a shot. 

Summary is that I'm seeing inconsistent VOD/guide issues across 2 STBs and cannot pinpoint a root cause.

Here's the details on my setup:
- Actiontec router from 7 years ago

- 2 STBs, I believe both Motorolas also from 7 years ago

- Internet works perfectly with normal speeds, TV picture itself is fine

And details on the issue:

- Started yesterday morning on one of the STBs; I attempted to use the TV guide and the box froze up, then after hitting a few more buttons on the remote (VOD etc) rebooted itself.  After the reboot, the STB reported having no network connectivity.

- I then checked my other STB which worked fine for TV, the guide, and VOD. I rebooted it just to see what would happen, and sure enough it then started having issues.

- The STBs will range from VOD working with guide information missing (showing channel names and icons, but missing the channel content) to having no network connectivity at all (External IP address = and VOD_112 error)

- Not being a MoCA 1.1 expert, I browsed around and my signals for both range from 230-240 per the router diagnostics page which seems strong. The STBs always show as being assigned an IP by the router, even when exhibiting issues.

- I've tried resetting the ONT, router (even a hard reset...painful) and STBs with mixed results.

- Eventually got everything working yesterday afternoon, it seems unplugging the STBs is more likely to resolve the issue than restarting via the menu system

- This morning, the STB that exhibited the initial problem freezes on the guide again. Didn't reboot itself this time though.

- Everything is working *at the moment* after another round of reboots..but something must be off here, and I'm not sure if it's within my network/equipment or Verizon's.  The fact that the issue spans 2 STBs would imply it's unlikely they are the root cause.  Perhaps it's time for a new router? 

Any help is appreciated!