UltraViolet/Disney Link Not Working!

Hey guys,

So I'm going mad trying to link my UltraViolet account to my FiOS Account. I've got over 100 movies on there and over 50 on Disney Movies Anywhere, which I guess is a whole separate issue.

Anyway, as it stands now, I've got my UltraViolet account connected to every service *except* Verizon and I thought it would be nice to connect it to Verizon. The Verizon account's in my Dad's name but I log in as him all the time no problem. So I'm in his Verizon account with full verified access and keep trying to link my UltraViolet account and it keeps returning back the error "Sorry you must be the primary account holder" which is weird because I'm logged in as him, and he's the primary account holder, with full access.  So I try to create a new UltraViolet account under his name, get to the FiOS page and same issue: "you must be the primary account holder"

Then I try calling into FiOS customer service, nobody there knows what to do. I've tried calling UltraViolet, they don't know what to do. I've tried Googling, nobody there seems to know what's going on, but other people have had this issue for a while.

So...does anybody at Verizon know what's going on? What I should be doing differently? I've tried this on just about every computer, phone and tablet in the house, logged in with full authentication, even the one where it has to text my Dad to get a code, and still nothing.

On a separate issue, it looks like there's a link to link my Disney Movies Anywhere account, and I'd like to do that too, but that doesn't go anywhere.