GizmoWatch not syncing contacts
Zplk12
Enthusiast - Level 1

We purchased a GizmoWatch late November 2018. I have a Google Pixel and the Verizon worker helped me set up the watch in the store. My wife has an iphone. I invited her through to GizmoWatch to be a Guardian and she accepted. We are both Guardians. However, on the watch, it is not syncing the contacts. The watch can only call my wife. We have since used the Gizmo Hub App to setup caregivers and these contacts are not showing on the watch at all! The caregivers have accepted the invitation and have permission to interact with the watch. I am the only contact that the watch will call and text. All contacts have created their own accounts on the gizmo app and accepted everything for setup.

We need the watch to sync to the Gizmo App so that all the contacts are listed on the phone and so the watch will both call and text the guardians and caregivers.

Labels (1)
10 Replies
chris148
Enthusiast - Level 1

Did anyone ever find a solution for this issue?

0 Likes
Reply
vzw_customer_support
Customer Service Rep

chris148,

 

Getting your GizmoWatch to fully work is a big deal. We want to make sure you can fully count on it. We're glad to help. What is showing up currently in the Gizmo App? What happens when you try to call this device?

 

AndrewT_VZW

0 Likes
Reply
dapmckenna
Newbie

Hi Verizon - Are there any solutions to get your GizmoWatch to update (sync) contacts from our App (GizmoApp iPhone 11) to my daughter's watch??????

0 Likes
Reply
vzw_customer_support
Customer Service Rep

dapmckenna, so we can better assist you, provide us with some more details as to what you're trying to accomplish regarding the Gizmo Watch. Are you trying to sync all the contacts off your iPhone to the Gizmo Watch?

TrinetteW_VZW

0 Likes
Reply
mjdelgado
Enthusiast - Level 1

My son has own a Gizmo watch since generation 1 and we never had an issue with syncing the contacts until this latest generation (Mickey Mouse). We are VERY familiar with the Gizmo Hub and the watch. He has had the same contacts in place for about a year now. A total of 5. I have had the same iphone so no changes here. I recently deleted 2 of his contacts and updated 3 new contacts on his watch via the Gizmo Hub. It updated on my iPhone but not on his watch as what everyone else is complaining about. The watch is now useless as only I can call him and none of his new buddies can make contact. If there is no fix, can we get a replacement. This terrible!!!

0 Likes
Reply
mjdelgado
Enthusiast - Level 1

I found the resolution and it works! You need to reset the Gizmo Watch. It will not reset the settings you have on the Gizmo Hub. You then can click the contacts you have updated on the Hub and assign them to the watch. It was easy. Hope this helps!:

GizmoWatch™ - Factory Data Reset (Powered On)
  1. Plug the GizmoWatch into the charger and turn on the GizmoWatch.
  2. With the device powered on, press the End/Back button to bring up the display.
  3. From the Home screen, quickly press the End/Back button 4 times. ...
  4. From the 'Reset Gizmo' screen, tap the Checkmark icon.
 
LRS3321
Newbie

Hi I thought I'd put it out there - we did do a factory reset for this same problem, and  now all our contacts are gone and they still don't sync the new ones.  My daughter is only able to call me.  So this may not be solution for everyone.  Verizon, PLEASE help fix this.  The gizmo is less than a year old!

0 Likes
Reply
vzw_customer_support
Customer Service Rep

Hello, LRS3321. We are sorry to hear that you are having trouble adding contacts after the factory reset. Click here and let us know which step you are having trouble with: https://www.verizon.com/support/knowledge-base-201104/.   

CassieG_VZW

0 Likes
Reply
Marcum0213
Newbie

It helped for me to manually re add them through app after reset. Works prefect now! Hope this helps. 

0 Likes
Reply
Hpulickal
Newbie

Click on each contact individually,  then assign it to the gizmo device.  I had to replace a device on warranty, and had to do that to get the contacts synced again.  

0 Likes
Reply