Verizon Galaxy Note 4 (2014) off eBay that's "Verizon + GSM Unlocked" won't stay connected to FIDO

Galaxy Note 4 (2014) off eBay that's "Verizon + GSM Unlocked" won't stay connected to FIDO/Rogers Network (Canada)


I suspect my Verizon phone may be blocking certain non-Verizon carrier bands or maybe geoblocking them? If so, anyone know how I can reach a service mode to turn on all the radios again? (I find dialer menu codes rarely work btw.)

My mom's old 2009 FIDO prepaid flip phone died (just wont turn on anymore, even when plugged in with keypad lit up), it used a regular/full size SIM card.

To replace it, I bought her a used Samsung Galaxy Note 4 (2014) Verizon phone off eBay that said it was "Verizon + GSM Unlocked". Phone's IMEI is verified clean/not stolen/not blacklisted (by myself on the web + FIDO & Verizon over the phone).

I myself own the same phone, an unlocked Verizon Note 4 I got used off eBay that I've used for 2+ years with Public Mobile without issue - connection, talk, text & 4G data all work great.

(Public Mobile is a discount carrier under Telus, one of the Big 3 carriers in Canada, the other 2 being Bell & Rogers.)

Needless to say, before buying the phone I confirmed it was compatible with the FIDO/Rogers network & it is - I've checked on the web & called FIDO who told me it was, + confirmed it's compatible with all the bands FIDO uses (though we only need it to connect for talk & maybe text).

(FIDO is a discount carrier of Rogers.)

Upon receiving the phone, I tested it for a week using my own Public Mobile SIM card without issue - it did not ask for an unlock code so I confirmed it was unlocked. Connection, talk, text & 4G data all had no issues.

Next I got her a new FIDO micro SIM card & over the phone had them transfer all her account details from her old SIM card to her new micro SIM. Before the end of the customer service call, the phone was connected to the FIDO network & successfully completed a test call to a local store (the call is logged & the account has shown minutes being used).

Then I tried to setup a web account to manage her account & successfully received a FIDO confirmation code text message which I still have.

I tried another call or two in the first hour or so without issue & then put the phone down to charge.

That was the last time I was able to use the phone with FIDO.

About 2 hours after setting up the new micro SIM, I turned the phone off to swap in her spare battery to charge it up. After rebooting, when I tried making a phone call it said it wasn't connected to a network.

No settings were changed. I thought maybe the SIM got dislodged so I reseated it & rebooted, but still no connection. Swapped back to original battery, reseated SIM, still no connection.

Tried FIDO SIM in my phone, no connection. Tried my Public Mobile SIM in my mother's phone again, all working fine on PM network. Called FIDO, all fine on their end, sent me a new SIM replacement.

Got the new SIM a few days later, again set up over the phone, account details again transferred to the new SIM. This time it wasn't connecting to the FIDO network before the end of the customer service call, they suggested it might take 10 or 20 minutes & to call back if I had any issues. Within 10 minutes or so it connected to FIDO but disconnected basically instantly before I could make a call this time. (Then again tried new/2nd FIDO SIM in my phone, no connection. Tried my Public Mobile SIM in mom's phone again, again it worked fine.)

Called back FIDO, all fine on their end. Went through diagnosis with their tech support, changing network mode settings, trying manual connections, nothing worked.

(Phone's 3 "Network Mode" options are "Global", "LTE/CDMA" & "LTE/GSM/UMTS" - tried'em all. Original setting used when it worked was "Global", which is the default.)

I notice on booting up the phone (every time), it shows the phone as connecting to the Rogers network & then FIDO with several bars before disconnecting & losing all bars before I can make a call, then says "Emergency Mode" only.

Youtube video of that:

After that I can't get any bars or connection again no matter what settings I play with (including toggling airplane mode) or even manually connect to the Rogers network (it simply times out & fails) unless I reboot (which just gives me the same insta-disconnect problem).

On Googling about Verizon phones being used on Rogers (& other networks) I've come across some forum posts suggesting that Verizon might block certain carrier bands the phone is capable of but Verizon doesn't use on its network &/or Verizon may be geoblocking certain carrier bands in other countries, both of which to make it harder to take the phone to a non-Verizon network.

If so, I guess I just lucked out with Public Mobile working? Anyway, I also read that supposedly there may be some hidden service menu I can use to turn back on radios that Verizon may have turned off. No idea how to get to it though. (The phone is not rooted, though I have experience rooting other devices.)

So I took this information to FIDO's customer service line, they found it interesting but hadn't heard of this before & couldn't offer any help, suggested I call Verizon. I called the local FIDO store about this too & they said the same.

Finally I called Verizon & they claimed they "don't do that" in regards to geoblocking or disabling a phone's wireless spectrum.. 😕 I doubt that, but in any case they were of no help & had nothing say about accessing any hidden service mode menu either.

Only thing I can think of now is to solicit advice from forums (planning to post this to several - *FIDO, *Rogers, Verizon & some smartphone tech sites). Anyone had this issue & solved it? Anyone know how I can get to a service mode where I can re-enable disabled radio spectrum? & if that's not the problem, any other suggestions?

Grateful for any help or insights anyone could provide.

(We were thinking of switching her to Public Mobile eventually, but she has about $100 in prepaid FIDO minutes we want to use up.)

*Couldn't post to Rogers or FIDO forums without customer account - can't setup FIDO web account because it requires you to receive a text message from them to set it up, which I can't receive since I can't connect to their network.. brilliant.

Re: Verizon Galaxy Note 4 (2014) off eBay that's "Verizon + GSM Unlocked" won't stay conne
Moderator Emeritus

These forums are dedicated to Residential products and services offered by Verizon.

For help with Verizon Wireless issues, please post your topic on the Verizon Wireless community.

Thank you.