Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
Google Pixel won't do wifi calling
KENERI20
Member

I have wifi calling set up via settings.    I live in an area with spotty cellular coverage and none in certain areas of my home.   I really need wifi calling and one of the reasons I switched to Verizon was to get a phone that was capable of wifi calling.   Ever since I got it I have had issues.  It seemed that if I had even a tiny, marginal cell signal it would default to cellular vs wifi.   But often it would connect with wifi and I would have good call quality.   Lately it won't connect via wifi at all.   My wife has an identical Pixel and hers will usually connect.    I have talked to Google about it and have requested a feature that would allow me to force wifi calling but they haven't been able to help.   I have tried contacting Verizon but haven't been able to figure out how to get support from them (I guess if they make it difficult enough it will bring their support costs down).    Verizon used to sell/provide microcells but my understanding is that they no longer do that and want people to use wifi calling.    That would be fine if it worked but it doesn't.   Is anyone else having this problem and does anyone have solutions/suggestions?   I have tried the things I have seen suggested on the forum but haven't had any luck.  

Labels (1)
0 Likes
Re: Google Pixel won't do wifi calling
Ann154
Expert
Expert

Do your settings look like this or something else?

Screenshot_20170421-165139.png

I'm most definitely NOT a VZW employee. If a post answered your question, please mark it as the answer.

0 Likes
Re: Google Pixel won't do wifi calling
KENERI20
Member

Yes, that is exactly what I am seeing

0 Likes
Re: Google Pixel won't do wifi calling
vzw_customer_support
Customer Support

Keneri20, thanks for reaching out to the community. We're always here to assist you. We're sorry to see that you've been dealing with this WiFi calling issue and haven't been able to reach technical support.

Have you checked your phone for the latest software update? When you go to Settings> More>  Cellular Networks is Data roaming on? Is the Advanced Calling setting on? You can always dial *611 from your device for support.

MarcusS_VZW

0 Likes
Re: Google Pixel won't do wifi calling
KENERI20
Member

Thanks for the reply.   I have the latest version of Android.  7.1.2, Advanced Calling was on.   I did note that Data roaming was not on but when I turned it on I got the same result.  My phone just will not go to wifi calling.    I think that I need a microcell, or as I believe the Verizon terminology is, a range extender.   I have spent hours on the phone with Google Support, talked to Verizon support about this some time ago and have recently worked with a person at my local Verizon store.  I have rebooted the phone, done a factory reset, and changed the SIM card and nothing seems to help.   As of a couple of weeks ago, the phone would occasionally (maybe 50 @% of the time) go to wifi when I made a call.  Since then, it hasn't done wifi even once.   I live in an area where I am extremely disadvantaged for cellular coverage and I discussed this issue with Verizon when I was considering a switch from AT&T late last year.   I was assured at the time that the wifi enabled phone would be a solution.  Instead, it has been something of a nightmare.

0 Likes
Re: Google Pixel won't do wifi calling
Tidbits
Sr. Leader

Is your service provider IPv6?  If so try and set up your router to IPv4 and then try again just for a test.  At times I notice WiFi calling has problems with IPv6 addressing.

0 Likes
Re: Google Pixel won't do wifi calling
KENERI20
Member

I disabled IPv6 in my router, which I assume causes it to default to IPv4, and it seemed to have no effect.   Thanks anyway.

0 Likes
Re: Google Pixel won't do wifi calling
RogerSC
Novice

I've recently purchased the new Verizon 4G/LTE Network Extender (femtocell/microcell) to use with my Pixel phone so that I don't need wifi calling at home. It is working well, 4 or 5 bars of cellular signal throughout my house. So, yes, Verizon is still selling femtocells, and the 4G/LTE model is vastly improved over the previous 3G model. Lots of status information, even a web admin GUI page with lots of useful Network Extender status information. It was expensive, which doesn't make me happy, but on the other hand is a one-time purchase that will make your life a lot easier.

Much better than switching to an iPhone to get wifi calling working when needed. In my opinion, Verizon should give a Network Extender to those that need them, especially if they have a phone that Verizon says that they support but will not support reliably. Like wifi calling on the Pixel, which they say is supported, but can't be used reliably.

0 Likes
Re: Google Pixel won't do wifi calling
Breece869
Member

I had same issue. I found that if you turn off your cellular data in settings you can then make a call over WiFi. Also I believe if you put your phone in airplane mode but turn the wifi back on you can also force the wifi call.

0 Likes
Re: Google Pixel won't do wifi calling
bic101
Member

When I was travelling abroad, WiFi calling worked well on my Pixel XL (android version 7.1.2; Verizon carrier). I received and made calls when connected to WiFi and roaming. When I'm home and in cellular range, by default it goes through the cell, not WiFi, even if WiFi is turned on. However, my connection is spotty from inside my house and  I want to make WiFi calls from home. The only way I seem to be able to do it, is to put the phone in 'Airplane Mode' and turn on WiFi, and only then does the Verizon Wireless icon change from "no service" to "Verizon Wireless Wi-Fi Calling".

I notice it says under "Wi-Fi calling" when I back out to the Settings > More > Wi-Fi calling page that under Wi-Fi calling it says, "cellular preferred" and that does not seem something capable of being changed.

So I just wish there is some other setting to provide me with an option to toggle between WiFi calling and Cellular calling when NOT roaming without first having to go to Airplane Mode.

(BTW, previous Android version said "Calling Preference" when you toggled it "on" instead of "Roaming Preference" as it now says. Is that a significant change?)

0 Likes