Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
Verizon Google Pixel roaming in Japan
tellular
Member

Had problems with Nexus 6P from Verizon in Japan last time.... very rarely could I get a data connection, usually just voice/SMS.

Despite Verizon saying I would get some data service, even if slow.

Upgraded to Verizon Pixel 128GB recently.


Went to Japan again, hopeful that the Google Pixel would work better.
Once again, I powered up the phone upon landing, and with the Cellular Networks -> Preferred Network Types -> Global setting, I got 5 bars of nice signal, but a little 'x' at the bottom right of the signal strength indicator, on the top right of the screen. Looking in About Phone -> Status, I could see an IP address, under Sim Status, it said Cellular network state was Connected, BUT... no data connectivity to the web.

I could not find a reason for that 'x' on the signal strength meter ... what did it mean. But despite all the other diag info showing I should be connected to the data network, I was not.

This went on for half a day. I then started messing around with Cellular Networks -> Preferred Network Types  and changed to:

Cellular Networks -> Preferred Network Types -> Global setting -> LTE / GSM / UMTS, and then selected JP Docomo as the Carrier.

That finally worked. I can't say what, but something finally 'clicked' and the 'x' disappeared, the carrier still showed as NTT Docomo, but in fact I was connected to JP Docomo and I had access to Google Play, Facebook Messenger, WeChat, etc...

Moreover, while Verizon website shows I should be on the $25 for 100MB of data plan, apparently I was on my daily Travel Plan ($10 /day for all you can eat on your current plan) ... which supposedly is not available in Japan according to VZW website. But I was on daily Travel Plan apparently as I never got a message about the $25/100 plan.

So if you have a VZW Pixel, you are going to Japan, try going into Cellular Network Settings, and choose LTE / GSM / UMTS and select the carrier and find JP Docomo, connect to it and see if that clears things up.

Just using the auto Global settings does not work!

Labels (1)