Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
Why does my Wi-Fi Callilng setting keep turning itself off on my Pixel?
bit_twiddler
Member

Is anyone else having a hard time with their Wi-Fi Calling staying on?

Labels (1)
0 Likes
Re: Why does my Wi-Fi Callilng setting keep turning itself off on my Pixel?
SuzyQ
Sr. Leader
Sr. Leader

The setting says it is on, and it seems to stay on wifi calling, but I'm not sure it's actually using wifi for calls.  Still trying to get a handle on wifi calling ... Pixel is currently in airplane mode with wifi on awaiting calls to see what happens.  But I shouldn't have to leave the phone in airplane mode ...

0 Likes
Re: Why does my Wi-Fi Callilng setting keep turning itself off on my Pixel?
bic101
Member

WiFi calling works for me only when I'm roaming and not connected to Verizon cellular. So when travelling out of the country, it received calls and I was able to make calls, but only to US phone numbers. When home and there is a cellular connection, the WiFi calling will not work, except in Airplane Mode, since that blocks it from cellular connections. Mine says "Cellular preferred" under Wi-Fi calling settings and there is no way of changing it. Mine also says Wi-Fi for "Roaming preference" when you click on  "Wi-Fi calling" (located under "more" in settings). There is no way of having non-roaming preference set to anything other than cellular preferred as far as I can tell. You can only force it to WiFi calling by placing it in airplane mode when not roaming.

And you cannot make international calls with WiFi calling (unlike Skype) either at home or when roaming.

0 Likes