Pixel 2 XL stuck in roaming Android 10
TJ_11
Enthusiast - Level 2

The update to Android 10 has been a mess for me. My cell coverage is all over the place now which is a drastic change from nearly full signal everywhere I went prior to Android 10. Now today, my phone went into Roaming and I cannot get it out of roaming. I've reset the networks, tried reboots, shut down for a while, and nothing is helping get rid of Roaming. 

Before I attempt a full factory reset has anyone else had this issue? I've had my phone for a long time now and factory reset is the last thing I want to do if it doesn't really help this. 

Labels (1)
9 Replies
gr8risheinme
Enthusiast - Level 1

FYI, I contacted Verizon and dealt with them a couple hours yesterday and we determined it was the SIMs card because we swapped my SIM card with another phone in our household and it corrected this problem. However I continue to read after I talk to them because I was supposed to pick my SIM card up today, but found a simple solution last night ...

 

Go to your apps, click on "see all # apps", then click on the three vertical dots in upper right hand of screen and select "show system". From here, scroll and find phone services, then storage and cache, then "clear storage". Then restart phone.

It may give a warning, but I did it and have seen no adverse effects. 

nairbdes
Enthusiast - Level 1

This worked! I spent hours talking to escalated Verizon support and we could not figure out why my Pixel 2 XL was stuck on domestic roaming. Clearing the phone services storage worked! Thank you!!

0 Likes
Reply
JosephDaniels
Enthusiast - Level 1

Thanks for the info.  This was an easy fix to an issue driving me nuts.

 

0 Likes
Reply
Thecookman
Enthusiast - Level 1

This got rid of the roaming icon for me. Thank you

0 Likes
Reply
MellyRivera
Enthusiast - Level 1

Thank you! That solution worked! I have a Pixel 2 XL on Android 10, just got back from International travel yesterday, and the service stayed as roaming. Your solution saved me a trip to the Verizon store and many hours of being on hold. Thank you!!!

0 Likes
Reply
TJ_11
Enthusiast - Level 2

This also seems to have removed my advanced calling features. I'm nonlonger able to turn on wifi calling, the setting isn't there anymore. Guess it's a Verizon store for me tomorrow

hac82
Enthusiast - Level 2

I have a Pixel 2 and I have had the same issues since the recent security upgrade on October 6.  I have the Roaming indicator always on in the notification bar with no way to turn it off.  I also noted that I no longer have WIFI Calling as an option in the Settings.  I have tried a reset to network settings, removed and re-inserted my SIM card and have ben on the phone with Google and Verizon.  Shy of a factory reset which I absolutely do not want to do, I may need to go to a corporate Verizon store and ask for a new SIM card to see if that corrects the issue.  The only other possiblity is wait out a possible fix from Google as they are realizing that this might be a repeated issue.  The agent I spoke to has heard of three cases himself.

0 Likes
Reply
vzw_customer_support
Customer Service Rep

We are truly sorry to learn that you are having issues after your device update. Please restart your device, and manually change your device settings. Steps in the link below. Keep us posted.

https://www.verizonwireless.com/support/knowledge-base-206364/      

MariaV_VZW

0 Likes
Reply
jvfage
Enthusiast - Level 2

Hi,

I had the same issue as did many others across the country in this thread.  However, several people have posted today that there is a new security update available.  Following the guidelines,  I just forced my Pixel 3 to check for a security update and now my Roaming issue is gone.  Hope this helps you too 🙂

0 Likes
Reply