Pixel 3XL not making WIFI Calls

I've been making calls from my house which is not close enough to a tower to have service in every room.  I've tried to turn on WiFi Calling several times, but for some reason the phone keeps telling me at the end of the call that it was unable to switch to WiFi Calling.  Is there something wrong with the phone or is there a setting that is messed up.

My home network is running at 400mbs through wifi and 1gb wired.  I've tested it several times and there are no drops in bandwidth anywhere in the home.

The phone is a pixel 3XL.  I've gone into settings and turned on wi-fi calling.  However it says under the Mobile Network section and wi-fi calling - Mobile preferred.  How do I change this?

Labels (1)
Re: Pixel 3XL not making WIFI Calls
Customer Service Rep

Aggiebryan, I depend on my calls to keep me connected, so I can see why you are inquiring about your signal. With Wi-Fi calling not working, it is imperative that we figure out a reliable solution for your calls. Seeing that it is a fairly new phone, I am determined to begin troubleshooting and provide a concrete solution. How does the phone indicate that the call was not processed through Wi-Fi calling? If you are able to get an error message on your screen, please provide me a screenshot here. What is your current signal indicator? What is the closest intersection and zip code of your problem area?

In order to fix your "mobile preferred" option:
Please go to the Wi-Fi calling section > Advanced > Wi-Fi Calling > Roaming Preference > Wi-Fi