Pixel XL wifi calling not working
dondon11
Enthusiast - Level 3

I have looked at other threads and none seem to fix the issue. 

Under settings:  More; I have selected Wifi calling on. 

in phone app wifi calling is turned on, I have selected to receive calls. 

Data roaming on, preferred network type is LTE/CDMA

My wife's iPhone can make wifi calls but has trouble with texting. 

I am using 7.1.2; but i also tried 8.0 DP3 & DP4.

I am using build version NHG470

I am using a Google Wifi mesh network with three nodes; I have tried IPV6 and IPv4 on my wifi network.  

I tried setting a static IP to my phone. 

I can make a call and it will connect with the other person, but the connection is only for a few seconds to a minute.   I can answer a call, but again only for a few seconds to a minute.   Any ideas on how to fix this?  

Labels (2)
0 Likes
Reply
1 Solution
dondon11
Enthusiast - Level 3

I think i have found the issue and will check when home tonight.   On the google pixel, a few menus do not work the same as on the one you buy from Verizon.   Plus, I guess the software is different. 

I had to key in one of the secret codes to see how my phone is set up.   You dial this sequence and it will enter an hidden menu.

*#*#4636#*#*

select phone info and check if VoLTE and video calling are enabled.  In my case, both were off.  Now the advanced calling is enabled and my wifi calling should work.  My Wifi calling was enabled already but did not work correctly.  

View solution in original post

14 Replies
SuperBillf
Enthusiast - Level 1

I have two Pixel 2 XLs in my home with very little, if any cell service available. Updating to the newest version of Android (Pie) has greatly improved my wifi calling, however it still tries to use the one pathetic little bar of 1X cellular connection whenever it is available. This is because Verizon has disabled our ability in the wifi calling settings to select "wifi preferred". Sure, the option is there, but it will not apply the change and will stay on "mobile preferred". The only way to force it to stay in wifi calling is to turn on airplane mode, which is not really acceptable because I don't always remember to turn it off when I leave the house.

I say we either need that option restored to us, or it needs to be modified so that mobile connection only takes over when it is strong, such as at least 2 bars of 4G (sorry, but 3G call quality just isn't acceptable anymore). I pay for my phone service to work, I expect it to do so whenever possible.

b1uebird
Enthusiast - Level 3

I'm using a Pixel 3a XL and the inability to set my phone to wifi preferred is still an issue! We have a network outage in our 1X area and I couldn't make or receive any calls at all until I found this thread.  But having to turn on airplane mode shouldn't be required.  Switching between the cellular network and wifi should be fairly seamless.

0 Likes
Reply
dondon11
Enthusiast - Level 3

I think i have found the issue and will check when home tonight.   On the google pixel, a few menus do not work the same as on the one you buy from Verizon.   Plus, I guess the software is different. 

I had to key in one of the secret codes to see how my phone is set up.   You dial this sequence and it will enter an hidden menu.

*#*#4636#*#*

select phone info and check if VoLTE and video calling are enabled.  In my case, both were off.  Now the advanced calling is enabled and my wifi calling should work.  My Wifi calling was enabled already but did not work correctly.  

andyubrrre
Newbie

I also fixed this by going to *#*#4636#*#* and going to phone information but I had no VoLTE options.

My info showed

Mobile Radio Power turned off

VoLTE = ON (greyed out)

Video Calling Provisioned = ON (greyed out)

Wifi Calling = ON (greyed out) 

EAB/Presence Provisioned = ON (greyed out)

I switched Mobile Radio Power to on which turned the Data Network Type from IWLAN to LTE and then my wifi calling worked once again. All other options still show as on and greyed out.

0 Likes
Reply
kh-taylarie
Khoros Partner
Khoros Partner

Due to the age of this thread, it will be locked in order to keep discussions current. If you have the same or a similar question/issue we invite you to start a new thread on the topic.

0 Likes
Reply
deviandia
Newbie

Same issue.

Have a SOLID Netgear Orbi WiFi network.  All other realtime WiFi is fine

VoLTE and Video Calling is grayed out. These fall under Mobile Radio Power, but I cannot change those settings

0 Likes
Reply
vzw_customer_support
Customer Service Rep

Hello deviandia,

 

We know how important it is to have a great working phone. What exactly is happening with your device? What are you trying to do?

 

ChristopherM_VZW

0 Likes
Reply
vzw_customer_support
Customer Service Rep

@DonDon11 Do you have a strong WiFi Signal? I'm curious do you have any other devices that lose signal while connected to WiFi?

JoelD_VZW

Follow us on Twitter @VZWSupport

If my response answered your question please click the _Correct Answer_ button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!

0 Likes
Reply
dondon11
Enthusiast - Level 3

No problem with wfi great signal. Issue is WiFi calling. I can make Skype calls or Google Hangouts calls.  WiFi calling is the issue.

0 Likes
Reply
vzw_customer_support
Customer Service Rep

dondon11, we absolutely understand your concern with this. Is this a recent development or have you not been able to use wifi calling at all on your Pixel? Have you been able to try from more than one wifi network?

JosephT_VZW

Follow us on TWITTER @VZWSupport

If my response answered your question please click the _Correct Answer_ button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

0 Likes
Reply
dondon11
Enthusiast - Level 3

I was using my old 3G network extender, but want to switch to WiFi.  My wife's iPhone 6S works okay on Wifi calling at home.  Mine does not.   So it is a new issue since I have not tried wifi calling before on my Pixel XL.  I only have poor Verizon network at home.   Can I force my phone to use wifi somewhere else?  Use Airplane mode or some other way?   

0 Likes
Reply
vzw_customer_support
Customer Service Rep

dondon11, we want to ensure you get WIFI calling working. This is a great indoor solution to make and receive calls. You mentioned you will try to change a few settings to see if it works, have you been able to get this up and running? Also, when trying this are you connected to your network extender? To check please dial #48.

TionnaB_VZW

Follow us on TWITTER @VZWSupport

If my response answered your question please click the _Correct Answer_ button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

0 Likes
Reply
dondon11
Enthusiast - Level 3

Yes, it is work now.  It was the menu issue.   Once the menu was fixed i could activate the VoLTE and now it works.   

0 Likes
Reply
d0x360
Enthusiast - Level 3

Still doesn't work for me and I tried his method

0 Likes
Reply