why can't I use wifi calling wifi preferred? (Pixel XL and iPhone 8 plus)
TheBZA
Newbie

I live in a fringe area, outside my house I can usually maintain enough signal to keep a call, however inside my house I can't. It's barely just enough service for Verizon to think that I should remain on cellular for calls, but often times (more than 5x per DAY) I miss calls that go directly to voicemail, and can't make outgoing phone calls.

I've tried toggling airplane mode to "force" it to go to wifi-calling, but when attempting to make a call it complains and says that I need to turn my radio on to make calls. I've tried rebooting multiple times per day with no avail. I've also tried literally everything i've found on these forums and others as well.

This has become a frustrating issue for me as I rely on my phone for work.

The last time i called support I was told that I should purchase a network extender. This makes NO SENSE to me whatsoever as the phones are fully capable of handling wifi calling without me having to spend $250 on a device just to be able to use my phone the way it was designed to be used.

Through a previous employer I had TMobile, I popped my tmobile SIM card in my Pixel XL and my Iphone and was able to have wifi calling absolutely flawlessly. I have a business grade internet connection, so I know that my home internet is not a problem to handle the minimal bandwidth for this.

I just don't understand why Verizon can't just let us use our phones the way they were designed, and to use a feature that was built into the phone from the factory.

Can someone please tell me what I need to do to get WIFI calling working properly? Why is this feature so elusive?

There was a point about a year ago where this feature worked fine on both the Pixel and the Iphone. It's been months since it worked right and it's really painful.

I really don't want to leave Verizon, but lack of consistently functional WIFI calling and the constant crippling of phone features is getting old and horrible. I spend really good money, over 200 per month on my phone service and over 800 per phone for 3x lines. I'm reluctant to take my business elsewhere if this isn't addressed or worked around in some way. I'm very frustrated that this is something I even have to post when it should just be a feature that works. The phone creator and other carriers have it working perfectly, why can't the largest and "best" carrier have it working?

Labels (2)
0 Likes
Reply
21 Replies
vzw_customer_support
Customer Service Rep

Staying connected is certainly important. We are here to help turn things around. To ensure we are on the same page , we do have a few questions. You noted a year ago all was working properly in regard to the Wi-Fi calling function. What has changed with your devices? (setting changes, software update, etc.) Has anything changed with your home internet? To confirm, is this issue occurring on both an iPhone 8 and Pixel? 

 

Jaime_VZW
Follow us on TWITTER @VZWSupport
If my response answered your question please click the _Correct Answer_ button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

0 Likes
Reply
TheBZA
Newbie

The issue does occur on the iphone 8, however not nearly as often. It seems intermittent, i.e at times the iphone has trouble and doesn’t remain on wifi calling unless I put it in airplane mode. Most of the time however it’s functional enough.

The Pixel XL however will not remain on wifi calling unless I’m on airplane mode, and even then sometimes it just says “turn radio on to complete call”.

This issue is almost always the case. Being able to force wifi preferred, which is an available option on the phone itself, however Verizon has the feature disabled, or forced to “mobile preferred”.

With android 8.0 it seemed to be a bit more consistent and functional. Perhaps the algorithm was better? Not sure why…

With 8.1 it was definitely a bit worse and more forceful in remaining on mobile network even when there wasn’t enough service to actually keep a call.

Now with 9.0 it’s virtually impossible to keep a call, and I end up missing the majority of my calls when I’m home.

Any help on this would be greatly appreciated, as this has become extremely painful. The real question becomes WHY CANT WE JUST SET IT TO WIFI PREFERRED?

0 Likes
Reply
deloused
Master - Level 3

In many cases that is actually how the phones were designed by the manufacturer, or by software developers. Switching providers wouldn't necessarily help with that issue, as even T-Mobile has gotten on board with Cellular prioritization over Wifi, just as At&t and Verizon already had-

iOS 11.3 nasty surprise: T-Mobile prioritizes cellular over WiFi calling - PiunikaWeb

The reasons are likely related to technical & safety feature issues that do occur over WiFi

0 Likes
Reply
TheBZA
Newbie

That’s almost comical, safety feature? Wouldn’t it be safer to keep wifi calling preferred in fringe service areas where wifi coverage is abundant?

As users who pay an enormous premium for our service we should have the option of setting this explicitly. When I was on t-mobile with an unlocked pixel I was able to manually select wifi-preferred.

I can also confirm as a developer/beta user on iphone 12.0 that they reverted this setting, so what was done on 11.3 is now fixed for 12.0.

The bottom line is, if the phone isn’t capable of deciding which threshold is “not enough” service signal to switch to wifi calling mode, than we as users should be able to decide the behavior. Anything else is just another decision being made for us.

Even if I had 5 bars of perfect signal at home, If I preferred being on my wifi network for something like radiation reduction, that should still be my choice.

0 Likes
Reply
deloused
Master - Level 3

"That’s almost comical, safety feature? Wouldn’t it be safer to keep wifi calling preferred in fringe service areas where wifi coverage is abundant?"

Not necessarily, many safety issues do occur.  Even with high speed wifi service networks do get loaded with traffic affecting call audio and connection quality. In many cases data traffic is given wifi bandwidth and channel priority over voice traffic.

Also, Wifi frequencies are unlicensed, and are therefore more prone to interference from other sources. Voice connections over WiFi channels are more likely to drop when moving out of range to cellular networks.

WiFi networks are easier to hack than cellular, which can expose users personal information and conversations. They also have a higher rate of incorrect location data which has affected app and website feature functionality, or can make it harder or impossible for police/rescue personnel to get to a user an an emergency.

0 Likes
Reply
TheBZA
Newbie

While I understand your point, how is it safer than my scenario? I have over 90% of my calls go to voicemail, and can’t make outgoing calls, yet still show 1 bar of service.

I’d take incorrect data, even a possible security concern over an inability to make/receive calls in the first place. In the years that I’ve had wifi calling work flawlessly, none of what you mention had ever happened to me.

Conclusion for me is, having my phone work is better than not.

0 Likes
Reply
deloused
Master - Level 3

I didn't mean to imply that it's safer for your specific scenario, just in general the reasons why the functionality is set that way.

0 Likes
Reply
TheBZA
Newbie

I can appreciate that.

This is why I go back to one of my original statements, if this was a user serviceable setting or threshold, people (I know I would) in general would be more satisfied with their overall experience and service.

Bottom line, it should be up to us.

0 Likes
Reply
VerizonSuuucks

In general much more dangerous to not receive calls from my son in an emergency. When is it safer to not be able to make or recive calls becauae my phone has 0.5 of a bar?

0 Likes
Reply
vzw_customer_support
Customer Service Rep

This is definitely not the experience we want you to have. We know it is vital to have reliable service, and we would be more than happy to help you today. Can you tell us a little more? When did this issue start? What services are being impacted? 

 

RachelM_VZW

0 Likes
Reply

I am also having this problem, and will switch to another provider if that will solve it.  I have been with Verizon for 10+ years and would hate to leave but my home has a metal roof and our lake house is in a fringe coverage area.  The phone will switch to wifi on MAYBE one in twenty calls but in general it just stays on the Verizon network which results in dropped calls.

 

Similar issues in some hotels, should switch to wifi calling but only does so very rarely.

0 Likes
Reply
barefoot-dave
Newbie

I use my phone for work and can no longer tolerate the poor call quality

0 Likes
Reply
vzw_customer_support
Customer Service Rep

barefoot-dave,

 

We value your loyalty and wouldn't want to see you go anywhere else. We want to make sure you stay in the Verizon family and can rely on things. The phone will default to cellular service if the phone thinks the signal is strong enough. I know the problem with that is that if the service is borderline it may sometimes pick wrong. There is a way around this. You can put the phone in airplane mode and then connect to Wi-Fi. As the cellular network won't be an option, any calls you make will need to go over Wi-Fi Calling.

 

AndrewT_VZW

0 Likes
Reply
TheBZA
Newbie

At least if we can’t set the setting to wifi preferred, raise the dB threshold to something less sensitive to the tower signal so we can actually make/receive calls.

0 Likes
Reply
VerizonSuuucks

@deloused wrote:

In many cases that is actually how the phones were designed by the manufacturer, or by software developers. Switching providers wouldn't necessarily help with that issue, as even T-Mobile has gotten on board with Cellular prioritization over Wifi, just as At&t and Verizon already had-

 

iOS 11.3 nasty surprise: T-Mobile prioritizes cellular over WiFi calling - PiunikaWeb

 

The reasons are likely related to technical & safety feature issues that do occur over WiFi


Yes switching providers will help. Verizon is one of the only providers that dont support wifi calling. Im switching to Google Fi. They support it. Bye Verizon. The final straw you disabling wifi calling this month

0 Likes
Reply
vzw_customer_support
Customer Service Rep

TheBZA, thanks for the feedback on your Wi-Fi Calling issues and the recent changes after the software updates. I get the level of frustration and wouldn't want to lose you as a customer. I completely get that buying a Network Extender is out of the question. Since Wi-Fi Calling focuses on a low signal to work by design, getting a moderate signal can at times impact how reliable Wi-Fi Calling will work indoors. I can fully agree on your question about setting Wi-Fi Calling to Wi-Fi Preferred. 

 

At this time the function/workaround aside from Airplane Mode, doesn't exist but I'll be sure to lift up the necessary feedback. If not already, you may reference the link attached to Clear Storage and Force Stop your Phone app. You can then test out your calls going forward. Keep us posted on any changes and we'll be glad to further troubleshoot the issue. http://spr.ly/6586DIzek

 

You may also reference our Wi-Fi Calling FAQ's page at the link below for any additional information. http://spr.ly/6587DIzeZ

 

 

 

AlanS_VZW
Follow us on TWITTER @VZWSupport
If my response answered your question please click the _Correct Answer_ button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

0 Likes
Reply
TheBZA
Newbie

VZW Customer Support,

Is there any way to get a bugfix or feature request in to enable this change? I can explain exactly which bits of code need to change for this to be viable.

If it wouldn’t void my warranty or EULA, I’d do it myself for my own phones…

0 Likes
Reply
vzw_customer_support
Customer Service Rep

TheBZA, I appreciate the good intentions and offer towards changing any code for Wi-Fi Calling to work better. I know the quality of how Wi-Fi Calling works is important to you. At this time, there is no bug fix or request we can create to enable the change for "Preferred Wi-Fi Only" for your Pixel XL or iPhone. I too would like to believe that future enhancements are coming to Wi-Fi Calling to ensure it addresses this exact problem.

 

You as the consumer do have the option of rooting your phone or software, but keep in mind it would void any existing warranty through the manufacturer or extended warranty through Verizon Wireless if applicable. This along with my original response is all the information we can currently provide.

 

 

AlanS_VZW
Follow us on TWITTER @VZWSupport
If my response answered your question please click the _Correct Answer_ button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

0 Likes
Reply
omar2
Enthusiast - Level 2

this same problem is on the Pixel 2XL.

It really bothers me that we can't tell the phone to prefer WIFI over mobile.  

at my house. my verizon signal is just too flaky..it only works in certain rooms...so when I'm on calls if I leave the room it drops the call.   I have to turn off mobile data to get my phone to stick to wifi....the wifi preferred should be a settable setting...android supports it.so why does verizon prevent that

 

0 Likes
Reply
n8leav
Enthusiast - Level 1

I am also frustrated by the fact that I can't enable Wifi preffered. I often have 1 signal bar in my house. I get so many dropped/missed calls throughout my days. It's beyond frustrating. I know for a fact, I can choose this option on other carriers with the same phone (Pixel 3XL). So it definitely is a setting that is disabled by Verizon.  The only way I can force it into Wifi calling to get stable service, is to put it in airplane mode and turn on wifi. However, to me, this is a bigger security concern because when I leave the house I sometimes forget to take it off airplane mode.  Just enable this option Verizon. It would be much appreciated by your customers with this phone.