Jet Pack model 5510 screen frozen on "mifi"and wont power off
TP1686
Newbie

When I powered on the jet pack it worked fine for a few minutes, then the front screen froze up and I could not power it off. I removed the battery and re-inserted and also tried the reset button I found with no luck using either. Does anyone have information on how to get this Jet Pack to work? I bought it to use on a two week vacation so that I could use it to do my work (all computer based), because we are staying in a very remote lake community  in Wisconsin with only a 3G tower nearby, no land line availability to hook up wi-fi through Century Link.  any suggestions?

Labels (1)
0 Likes
Reply
1 Solution
John_Getzke
Champion - Level 1

If the Jetpack is having power issues then I would contact VZW and request warranty support.  VZW should be able to send you another device at no cost.

If you are out of warranty and the device does not boot correctly then you may be out of luck.  Fortunately new 5510s can be found for relatively cheap and you can migrate the service from one device to the new one.

View solution in original post

0 Likes
Reply
1 Reply
John_Getzke
Champion - Level 1

If the Jetpack is having power issues then I would contact VZW and request warranty support.  VZW should be able to send you another device at no cost.

If you are out of warranty and the device does not boot correctly then you may be out of luck.  Fortunately new 5510s can be found for relatively cheap and you can migrate the service from one device to the new one.

0 Likes
Reply