Why does my Jetpack indicate "No Service"?
ohforf
Newbie

On the 24th, I signed up for Verizon 4G service. I bought a pre-owned Jetpack (model 6620L) direct from Verizon. The device arrived today. It seems to be functional, but isn't connecting to 4G. "my.jetpack" indicates that there is "No Service" and that my "wireless number" is 000-000-0000. Under "my devices" in "My Verizon" here on the site, it shows there is a device on my account. However, I cannot change this device. I cannot add a device.

I have no idea what to do. I can find no instructions for this situation anywhere on the Verizon site, in the jetpack documentation, or any of it's menus. I called Verizon, and the rep told me it would be working "in a few minutes" and "there was nothing else I needed to do". It's been well over an hour.

What do I have to do to make this work?

(edit: And yes, I have a very strong 4G LTE signal from Verizon. I have a Verizon phone which has a good signal. I have tested the area with OpenSignal, and I know it's a Verizon signal.)

Labels (1)
0 Likes
Reply
1 Reply
John_Getzke
Champion - Level 1

This is a device activation issue.  Verizon will have to help you out.  Try Verizon support again.  Chat, phone or in-store rep should all have the tools necessary to get you working.

Something hasn't refreshed on the new Jetpack between your account and the device itself.  VZW can try additional activation requests and confirm if the correct information is recorded on their site for the Jetpack.  Keep your Jetpack Phone number, SIM number and IMEI number ready to go when you contact VZW again.

Otherwise activations are an automatic process. They are not instant so waiting one hour isn't much of a concern to me.  It may start working for you by the time you read this message.