Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
cancel
Showing results for 
Search instead for 
Did you mean: 
Kin twom Wi-fi not working... really frustrated
hanbaebae
Member

I have a WPA 2 network however, when I try to connect to my wifi it says " can't connect to the NetPro network right now. try again later" I have not had the oppurtunity to try this for any other networks. However, I did try a random password for my neighbors, and instead of a message coming up as password invalid or something like that I got the same message. How do I connect to my wi-fi?

0 Likes
Re: Kin twom Wi-fi not working... really frustrated
SydneyK
Sr. Member
Sr. Member

I have had this problem too, with my home WPA2 router, and haven't yet found a solution without playing around with my router settings. I unplugged my router to reset it, and it worked for a while but then gave me problems again. I was able to connect effortlessly to open networks, like at Starbucks, though.

 

I wish I had the answer. There are some knowledgeable Kin users here though who might be able to help you. Post back with the solution once you figure it out, K?

0 Likes
Re: Kin twom Wi-fi not working... really frustrated
hanbaebae
Member

Aww. I haven't figured it out yet either. Keep me updated if you figure it out!

0 Likes
Re: Kin twom Wi-fi not working... really frustrated
crimedoggies
Sr. Member
Sr. Member

hanbaebae wrote:

I have a WPA 2 network however, when I try to connect to my wifi it says " can't connect to the NetPro network right now. try again later" I have not had the oppurtunity to try this for any other networks. However, I did try a random password for my neighbors, and instead of a message coming up as password invalid or something like that I got the same message. How do I connect to my wi-fi?


Is your router broadcasting N or B or G?  The Kin2M is not compatible with N technology.

0 Likes
Re: Kin twom Wi-fi not working... really frustrated
Ms_Shonta
Novice
Power the device off and then back on. 
1 Tap a network to connect to it.
2 If required, you’ll be prompted to type a password. Networks secured with passwords display a padlock next to their signal strength.
3 You can manually connect to a network that’s not listed by tapping Other.
4 Once connected, you’ll see the connection status below the Wi-Fi setting name, and when you open the Dashboard you’ll see the connected signal strength in the top row.
5 If you tap the connected network on the Wireless settings screen, you can choose to forget this network, which means you won’t connect automatically when the network is in range. If you want to check or update the IP from the access point, tap renew lease.
0 Likes
Re: Kin twom Wi-fi not working... really frustrated
SFDemon
Member

I just got my KIN TWOm a couple of days ago.  I'm trying to connect to to WiFi.  I see my network on the phone, then try to connect and after entering the passoword ( I know the password is correct), it gives me an error message saying  " NOT CONNECTED Can't connect tot he "networkname" network right now.  Try again later.  My router is a Belkin N1 Wireless router.

0 Likes
List Your Router!
Simplify
Member

Just a thought:

 

I am a new KIN TWOm owner (not an expert) so I frequent this site to learn about my new phone:

 

I have an Airport Extreme 802.11g.  I am currently using a WPA2 locked network.  I had no problem signing in with the the KIN TWOm.  My router is pretty old.  I do not have the newer 802.11n one.

 

I just looked in the manual under wifi and it does not specify compatible routers but I do recall reading that the newer 802.11n is not supported.  This was on a forum and not in the manual.  (Oops!  It is in this thread!) :smileysurprised:

 

I'm glad I have not upgraded my router in years because mine seems to be working with my KIN TWOm.  

 

So, is it the phone or the router?  I don't know? 

 

I will say that I have to remember to turn wifi off of a device (KIN TWOm, iPod Touch, MacBook etc ...) I am taking with me before I leave the house because while I'm gone the entire network shuts down.  If I turn wifi off in the device I am carrying out of range then the home network keeps working.  If I forget to turn it off of the device I am traveling with, I have to restart the network by physically unplugging it, count to 10 slowly, plug it back in, then everything just starts working again without having to retype the password.  It doesn't work if I just reset it from the ethernet device.  Leaving the house with a device that has wifi on connected to the home network knocks out everything connected to the network, iPod Touch, computers, etc ...  Once I unplug & replug the network in, everything just works again within about a minute or so.

 

I figured that out the hard way with my iPod Touch.  My family kept complaining that the network was down and I noticed the pattern of whenever I leave the house with my iPod on wifi the network goes down.  It's the same with my KIN TWOm and my MacBook.  I don't know if it has to do with firewall settings or network settings or what?  I just make it a habit to turn off wifi on the device I am carrying with me before leaving the house.  I can still turn it back on once I am out to access public wifi.  Then it still works for the rest of the family while I'm gone.  When I return home I have no problem reconnecting to my home network.    

 

I hope this is clear enough.  It's hard to explain in writing.

0 Likes
Re: List Your Router!
SFDemon
Member

Well...... Ms_Shonta from Verizon what do you have to say to Simplify's post???  Is it true that this KIN Twom is not compatible with an N router?  That would be very stupid.  This is a new phone, why would it not be made compatible with an N router?  that would NOT make any sense!!

 

Thank you Simplify!

0 Likes
Re: List Your Router!
Simplify
Member

You're Welcome.  I'm sorry I didn't post better news.  :smileysad:

 

It is pretty surprising but I was just reading about the phone on Amazon and under key features it states:

 

Wi-Fi networking (802.11b/g) for accessing home and corporate networks as well as hotspots on the go.

 

Why in the world isn't this stated in the manual?  That is just ridiculous to me because as you stated 802.11n is not exactly new technology and this phone is new!  There are so many posts on this issue and I do not see one where the issue was solved.  Sad.  Maybe you can locate a 802.11 b/g router for a low price and just run a separate little network or something?  

 

So, now you know the rest of the story.

 

No 802.11n for the KIN. :smileysad:

 

KUDOS crimedoggies!  That poster actually solved this in a post above in this thread.  I just realized that so many KIN owners are having this issue and I wanted to know why mine worked and a lot of other peoples wouldn't.  

0 Likes
Re: List Your Router!
RTFM
Novice

I've done some digging, and here's what I've come up with...

 

Most N routers will connect to both N and G devices. If the KIN does not support 802.11n, that doesn't automatically mean it won't connect to an N-router -- unless the router is set to use ONLY 802.11n, or is a dual channel router set to transmit only at 5MHz.  (A wireless G device can only use 2.4MHz.)

 

So if you are using the KIN with an N router and it won't work, make sure the router is set to mixed mode, so it will support both N and G devices.  I would think that should be the default, but I don't really know.  (I have no idea how to actually change the router settings...this is just something I read while trying to research this.)

 

I have an old Netgear G router here at home and my KIN connects fine.  My daughter has a single band N router at her house, so next time I'm over there, I'll see if I can connect to that.

0 Likes