Skip to main content
Accessibility Resource Center Skip to main content
Get up to $500 when you bring the phone you love. OR get iPhone 13, on us. Online only. With Select 5G Unlimited plans. Ends 1.31. Buy now
end of navigation menu
Factory reset isn't working on my Revo!!
jandern3
Newbie

I was beginning to create a backup for my phone, as I have learned the hard way that LG Revolutions need to be reset somewhat frequently.

I tried to back it up, and it shut off instead. It looked as if it was about to reboot, but instead it got stuck on the LG boot-up screen. I restarted it multiple times, and one time left it for 30 minutes to see if it would change, but nothing happened.

I then tried to boot up in safe mode several times, again to no avail.

Finally, I resigned myself to a factory reset, but it wouldn't even do that! After holding the power and volume-down buttons, the reset screen came up as normal. I then pressed the power button twice, as directed by the phone, but it just went back to the LG screen. It stayed like that until I pulled the battery nearly 40 minutes later.

I have since attempted more than 10 resets, every time hoping that something different will happen.

Well played Verizon, you have made me the literal definition of insane.

0 Likes
Re: Factory reset isn't working on my Revo!!
AntonioC_VZW
Verizon Employee

Hi jandern3,

I am sorry to learn that you are not able to reset/power on your phone. It seems like you have done every thing I would recommend to reset/power the phone on. Please be assured that we'll be happy to process a Certified Like New Replacement as per the one year warranty (Does not apply if liquid/physical damage).

Please note that Removing/Reinserting the SIM card reprograms your phone. I don't see that you have tried that in your post. Please give it a try as it may resolve the issue.

AntonioC_VZWSupport

Follow us on Twitter at www.twitter.com/vzwsupport

0 Likes