Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
LG Revolution and Exchange Active Sync
lfred150
Newbie

I had no issues with our old Exchange provider and when we changed to our new provider (Intermedia), we cannot use the stock Exchange connector in the stock mail app.  I have imported the certificate on the phone and then when I enter all of the email setup information, the phone says: Error: This server requires security features your phone does not support.  I contacted their helpdesk and they are aware of the issue and they are saying it is the latest build of Android and how Verizon has tweaked it for this phone.  I have searched high and low and there are many posts about it not working and it all points back to the Verizon/LG build issue.  Of course they say use Touchdown and I don't like that at all. (it does work with no issue).  I called Verizon tech support and they could not understand the issue.

 

I also loaded the latest Revolution update thinking it would resolve this issue and no luck..Any other help from this community?

 

Leo

 

0 Likes
Re: LG Revolution and Exchange Active Sync
webdon
Enthusiast

Try k-9 or the paid version Kaitlin.

 

If you have special needs that the default does not support, you probably won't get special programing either from Google or Verizon. Or use the version your support staff say to use.

 

I want purple corn but I settle for yellow.

0 Likes
Re: LG Revolution and Exchange Active Sync
thehouseofho
Newbie

It's possible your new email provider has enabled security features that surpass the capabilities of most smartphones. There is a setting in Exchange to only allow fully provisionable mobile devices access to ActiveSync. Unfortunately, the only fully provisionable mobile operating system is WinMo 6.5. I would recommend you contact your provider and have them send you all of the security features they have enabled for mobile device access and go from there.

0 Likes
Re: LG Revolution and Exchange Active Sync
prenvzw
Newbie

Don't give advice if you don;t know what's going on. The LG stock mail client just sucks. Get touchdown or other paid mail clients for Android you will be able to get the exchange to work fully. You don't need winmo or windows phone 7. 

0 Likes