Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
LG G3 needs Lollipop!
richenk89
Member

I just got this phone a couple months ago and I cannot upgrade my software to the Lollipop!  Why?  I feel this is miss leading customers as this being the newest phone but the software is already outdated before I even got the phone!

Labels (1)
0 Likes
Re: LG G3 needs Lollipop!
vzw_customer_support
Customer Support

@richenk89

I anticipate upcoming updates as well!  Although no information is currently available, stay informed by visiting here: http://vz.to/1KrCOiE.  Thanks!

AnthonyTa_VZW
Follow us on Twitter @VZWSupport

Re: LG G3 needs Lollipop!
Snn5
Sr. Leader

Rumor is, is that it is rolling out now to 5.0.1.

0 Likes
Re: LG G3 needs Lollipop!
GalaxyClass
Sr. Member

Let's just hope they get it working on this update.

Re: LG G3 needs Lollipop!
Not applicable

richenk89 wrote:

I just got this phone a couple months ago and I cannot upgrade my software to the Lollipop!  Why?  I feel this is miss leading customers as this being the newest phone but the software is already outdated before I even got the phone!

How is a phone that CLEARLY labeled as having KitKat misleading customers when it comes with KitKat? When the G3 came out KitKat was the latest OS. LG makes the updates by the way so if it's too slow for you blame them.

0 Likes
Re: LG G3 needs Lollipop!
richenk89
Member

Thanks for the feedback.

0 Likes