Skip to main content
Accessibility Resource Center Skip to main content
Get up to $500 when you bring your phone. Plus, waived smartphone activation fee when you buy online. Limited time offer.
end of navigation menu
cancel
Showing results for 
Search instead for 
Did you mean: 
Forcing phone to use wi-fi calling
MARGUE44
Member

Motorola Droid with Android 8.0.

I get a weak cellular signal at my new workplace, I have wi-fi calling turned on, but since it is picking up a weak cellular signal it goes with that instead of wi-fi and I can't get, make, or receive calls well or sometimes at all.

Is there any way to force my phone to do internet calling even when receiving a weak cellular signal?

Alternatively, I have tried to turn on airplane mode and then turn wi-fi back on and call, but it says I can't make calls when in airplane mode.

I HAVE chosen "Prefer Wi-Fi" in the settings for "When roaming".

Labels (1)
0 Likes
Re: Forcing phone to use wi-fi calling
Ann154
Expert
Expert

There are dozens of Motorola phones that have Droid in the model name. Please be more specific about the exact model name you have.

I'm most definitely NOT a VZW employee. If a post answered your question, please mark it as the answer.

0 Likes
Re: Forcing phone to use wi-fi calling
boringusername
Sr. Member

you can make wi-fi calls in airplane mode as long as wi-fi is turned on that alert is just referring to cellular calls.

0 Likes
Re: Forcing phone to use wi-fi calling
MARGUE44
Member

Moto Z Play Droid

0 Likes
Re: Forcing phone to use wi-fi calling
MARGUE44
Member

The only two choices I am given when I try that is "Cancel" (not continue trying to make the call) or "OK" to turn airplane mode off

0 Likes
Re: Forcing phone to use wi-fi calling
joey2007ua64
Novice

MARGUE44 wrote:

Alternatively, I have tried to turn on airplane mode and then turn wi-fi back on and call, but it says I can't make calls when in airplane mode.

I have only seen that message a couple of times when my phone has been running for weeks without a restart.  I usually restart my phone once a week and it works without issue.

I have a Moto Z Play Droid running 8.0.  After placing the phone in Airplane mode, turn on Wi-Fi and wait for Verizon Wireless Wi-Fi Calling to appear before trying to make a call.

Screenshot_20180711-174203.png

0 Likes
Re: Forcing phone to use wi-fi calling
MARGUE44
Member

Never Mind.  I found out that my employers firewall does not allow for wi-fi calling so it.  It works fine elsewhere.

0 Likes
Re: Forcing phone to use wi-fi calling
vzw_customer_support
Customer Support

Thanks for letting us know that you identified your employer's firewall is the source of the issue with Wi-Fi calling, MARGUE44. Just to clarify, does this resolve your concern for now?  

Ryan_VZW
Follow us on TWITTER @VZWSupport
If my response answered your question please click the _Correct Answer_ button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

0 Likes
Re: Forcing phone to use wi-fi calling
vzw_customer_support
Customer Support

Thank you for reaching out, we are sorry to learn that you are having trouble with WiFi-Calling. I know it can be frustrating not being able to use your phone as you want. Try resetting the network on your phone and then trying again. Here is a link with the steps to reset the network: https://www.verizonwireless.com/support/knowledge-base-206440/ Thanks. 

 

Roger_VZW
Follow us on TWITTER @VZWSupport
If my response answered your question please click the _Correct Answer_ button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

0 Likes