Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone. OR get iPhone 13, on us for a limited time. With Select 5G Unlimited plans. Buy now
end of navigation menu
3rd Party Apps won't uninstall or display correctly in App Manager

I've found that my Razr, like most devices, needs housecleaned every so often to perform at peak.

I regularly (monthly-ish, or whenever the device seems bogged-down) clear the cache partition, and houseclean the App caches.  Some of them get very cumbersome, and it does seem to help app performance.

I've noticed that sometimes some apps, randomly (not consistent cuprits, though it seems to be whatever I use most often or whatever moves a lot of data around) don't update in the app manager, and when they're like that, you can't uninstall or do anything with them, even though they run fine.  Fine, but like molasses in January.

For this, I'm having trouble with Megapolois and Words With Friends.

Going to the App Manager -> 'All' and going to either app yields all the fields populated by "Computing..."   and it just stays that way.

I've tried to unistall the app from there, thinking something was just hung-up, and the "Uninstalling.." screen comes up...and the bar moves, and it does nothing.  Forever.  Same when I try to uninstall from the App Store.  App Store -> My Apps -> [App] -> Uninstall.  Circle spins, it says its uninstalling, but 90 minutes later, there we sit. 

In both cases, I can't back-out of the action.  I can go back to the home screen, but I can't get back to "Manage Apps" or the Play store as appropriate without it going right to that stalled operation in progress.  I have to reboot the phone.

I've tried in Safe Mode with the same result.

There must be a way to nuke/reset these apps from the recovery menus somewhere.  How?

I also have a bunch of apps, Maps for instanance, where I can't clear the cache.  Push the "Clear Cache" button, it lights up blue...and the cache doesn't clear. 


Labels (2)
Re: 3rd Party Apps won't uninstall or display correctly in App Manager

You May Have to Run a Factory Reset are you running the Latest OS 4.1.2 if not I'd run the F.R. followed a System Cache Clear then Update to 4.1.2. if you haven't..