Cannot turn on Droid HD Razr

My phone completely died, a quick message that mentioned "Android Failed" popped up and then the SD card icon eliminated. I saw that I had 52% battery and only 2 apps up, Kindle and Yahoo.  Then the message pops up again and poof it shut down.  No warm reboot or anything it is cold dead. I have never had this happen and the phone has worked great for this past year up until now. I tried to check the card and it looks fine, no cracks the cradle is tight.  The power button does nothing. 

Any of the troubleshooting doesn't account for the fact I cannot turn it on at all.  Even if I try to access it with my PC, it's not able to see anything.

At the time I was reading on my lunch break and there was no physical trauma to the phone.

Labels (2)
3 Replies

I am in the same situation, however, when I've tried to get the boot menu, nothing happens. Was working fine and was fully charged. All the sudden won't come back on. Is it an update causing the issue? Talked to both Verizon and Motorola support with no success other than "Send us the old phone and $150 for a new one" - this is the only way my clients can contact me for work! Not acceptable!

Customer Service Rep

Yikes! Sorry to hear your phone bailed on you.  I know how much we rely on our phones so if my decided to take a vacation I would not be a happy camper.  I want to have you try trouble shooting step that usually works for me. Please try holding the volume down and power button simultaneously while your phone is plugged in to the charger. Keep us posted to see if that worked for you.

Follow us on Twitter at @VZWSupport

Enthusiast - Level 1

I find this amazing that the same thing is happening simultaneously to Droid HD Razr owners. Hmph.

My phone has been acting weirdly since the update - apps turning off and interrupting calls, battery loss and of course the heat. Now it just turned off yesterday - after a full charge,mind you - and would not come back on. I finally pressed the power button and volume and it started the familiar 'DROID' sequence, only to get stuck on the 'red eye'. Nice.

Useless for a day now. I keep retrying and finally get the screen that says:

AP Fastboot Flash Mode

Device is locked, Status Code: 0

Battery OK

Transfer Mode: USB Connected

Fastboot Reason: Key pressed

But of course, I cannot download anything from the phone to the PC. Useless.

So now what? Day 2 without phone. Not happy.