Has anyone had any issues with connecting to enterprise wifi connections using 802.1x EAP? Tried it on two Droid Turbos but it will not connect.
DefaultUserOne

Just bought two Droid Turbos (64GB) and updated the system software.  Tried to connect to our corporate wifi using the same settings that we use on all the other Android/iOS devices.  Next to the network name it shows  "Saved, secured with 802.1x EAP" but will not actually connect to the network.  Tried a factory reset, updates, removing/readding the network, 3rd party wireless connection software to no effect.  It appears that it's a certification issue.

Called both Motorola and Verizon and they point the finger at Google.  Really don't want to take the phone back but not being able to connect to wifi in my office has made my battery barely last a day.

Labels (2)
0 Likes
1 Reply
malthus
Newbie

Yeah, I wouldn't point the finger at Google, unless you blame them because they owned Motorola until a week ago.  I bought a Moto X 2nd gen and had the same problem.  A little googling and I found the likely answer, the new Moto X (and likely the new Droid Turbo, also made by motorola) enables 802.11w, with which older Cisco (and related) routers do not support.  It is possible for your sysadmin to update the router firmware to support newer 802.11 protocols like W but that will depend on their competence and your juice.  A couple of links about the problem:

https://supportforums.cisco.com/discussion/12331486/connectivity-issues-cisco-controllers-and-pmf-en...

https://forums.motorola.com/posts/8551249ce8

I don't know why other android phones don't have a problem connecting to 802.1X networks.  They may not have implemented 802.11W or they may failback to an older protocol more gracefully, which Motorola chose not to do.

0 Likes