MMS messages and pictures won't send
NITTORIDER02
Enthusiast - Level 1

I have a Droid Turbo 2. My MMS messages as well as pictures will not send to recipients. They just say "sending" but never do. Normal text come and go just fine though. I've tried doing a hard reset, but nothing changed. Please help!

Labels (2)
1 Solution
WRUser
Enthusiast - Level 2

Thank you. I tried changing the settings for data and nothing changed. Then I did what I probably should have done in the first place. lol. I took the battery out for 30 seconds, put it back in, and was able to send and receive pics again. Thanks for trying to help me.

View solution in original post

0 Likes
Reply
8 Replies
vzw_customer_support
Customer Service Rep

Hello NITTORIDER02! Let's get your MMS messages flowing in again for you. To clarify further, are you able to send/receive regular text messages and or connect to data/internet (when Wi-Fi is off)?


KristieQ_VZW
Follow us on Twitter @VZWSupport
If my response answered your question please click the "Correct Answer" button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

0 Likes
Reply
WRUser
Enthusiast - Level 2

This is happening to me too. Started on or before July 12. I have an LG Vista. My zip code is 31088. Won't send MMS messages even when connected to WiFi. I have not used any data. It is not time for my plan to renew. Shows a message stating I am not connected to the network. Sends and receives SMS messages perfectly. Thanks. Tried to re-send pics that I have sent previously. Doesn't work.

0 Likes
Reply
vzw_customer_support
Customer Service Rep

WRUser,


Let's get you connected sending your MMS. You can go to Settings/Data Usage. Please make sure your Mobile Data is turned on. Also make sure you do not have Limit Mobile Data Usage turned on. Please toggle these as well and test again.



RobinD_VZW
Follow us on Twitter @VZWSupport
If my response answered your question please click the "Correct Answer" button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

WRUser
Enthusiast - Level 2

Thank you. I tried changing the settings for data and nothing changed. Then I did what I probably should have done in the first place. lol. I took the battery out for 30 seconds, put it back in, and was able to send and receive pics again. Thanks for trying to help me.

0 Likes
Reply
vzw_customer_support
Customer Service Rep

Oh good. We are glad to see things are back to normal with the picture messages again.


TamaraH_VZW
Follow us on Twitter @VZWSupport
If my response answered your question please click the "Correct Answer" button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

0 Likes
Reply
mdefrancesco
Enthusiast - Level 1

My husband and I both have been having the same issues. MMS will not send, images, gifs etc. SMS will send just fine. We both had pixels when it started (2 and 3XL) and tried resetting our network settings, toggling mobile data on and off etc. Figured maybe we had bad antennas and just upgraded us both to the galaxy S20 (+ and ultra). Same issues. Reset network settings, turned mobile data on and off, turned wifi on/off, made sure data was not set to limited. Nothing is working. Don't believe I should have to do a hard reset of the phones since they are brand new. Less than 1 day old. But these phones have internal batteries so I cannot take the battery out. 

KH-Michael
Moderator Emeritus

Due to the age of this thread, it will be locked in order to keep discussions current. If you have the same or a similar question/issue we invite you to start a new thread on the topic.

0 Likes
Reply
deloused
Master - Level 3

MMS needs to connect to the Verizon data network to send and receive

0 Likes
Reply