Making WiFi calls when Airplane Mode is enabled on Droid Maxx 2

My Droid Maxx 2 phone supports WiFi calling.

My home has very poor cell service.  Therefore, I installed a 3G Verizon extender a couple of years ago.

However, this past November my phone "upgraded" to allow WiFi calling (November 2016 upgrade) and also provided 4G cell capability.

Well I have a 3G extender and my phone won't use the 3G extender as it keeps looking for 4G which is faint.

Therefore for three months, in my home, I could turn on Airplane Mode (which turned off the cellular connection), turn on WiFi, and then make and receive calls anywhere in my house (including my basement office) using WiFi.

However, at the beginning of February 2017, and some "app upgrade", that all stopped. 

Now, if the phone is in Airplane Mode, it won't use the WiFi calling, period.

And if the Airplane Mode is Off, then the phone sees a faint (barely)  4G cell signal and refuses to switch to WiFi calling, but will lose cell connection during calls.

What is the good of WiFi calling, if I can't use it when I need it??????

Is there a software fix? 

Why can't I tell the phone to use WiFi calling when the cell service is one bar or less?


Labels (2)
Re: Making WiFi calls when Airplane Mode is enabled on Droid Maxx 2
Customer Service Rep


WiFi calling is a beautiful feature and we want you to be able to take advantage. Airplane Mode is a setting that is meant to disable all radios on the device from cellular to WiFi and bluetooth. Rather than using this setting have you attempted to disable celluar data by itself? This should allow you to keep the WiFi radio on so you can still make WiFi calls. See how to Turn Cellular data Off / On here

Follow us on Twitter @VZWSupport
If my response answered your question please click the "Correct Answer" button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!